The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

View Stats:
Chelsea! Jun 7, 2014 @ 9:28pm
Problem with a Dragon in Neloth's Tower
I'm playing through the Dragonborn DLC and am on the quest The Path of Knowledge to go talk to Neloth in Tel Mithryn (mushroom tower). When I go into Neloth's tower, there's a Revered Dragon in there fighting him and doing weird teleporting fly-bys in/out of the room. I've found nothing on Google about this particular problem so I can only assume he's not supposed to be there. I can get the dragon to no health but because he's teleporting (and in the tower) he won't land so he can't die. Neloth is of course stuck in infinite limbo valiantly fighting the dragon and won't stop to acknowledge me.

I don't really see a way around this glitch so I'm wondering if anyone has a surefire way to remove random dragons from the game so I can continue the main Dragonborn questline?
< >
Showing 1-8 of 8 comments
Foxbyt3 Jun 7, 2014 @ 10:46pm 
Did you try to open the console by pressing ^ , click on the dragon and type disable? It should remove the Dragon and should get Neloth out of combat.
Jogon Jun 8, 2014 @ 3:33am 
Very strange. Never came across that one. Perhaps you have a mod conflict going on. Try running BOSS and see if that could be the problem.
SpeedFreak1972 Jun 8, 2014 @ 3:56am 
By any chance deadly dragons installed? Had problems with that mod too (a dragon attacked me through the roof of labirinthian)
GenRabbit Jun 8, 2014 @ 6:14am 
When I get dead dragons falling down, I mark them and write markfordelete as command.
I think Disable alone, won't remove it. Just disable it.(disable will only make it invisible, but its still there I mean)
Last edited by GenRabbit; Jun 8, 2014 @ 6:16am
Chelsea! Jun 8, 2014 @ 10:26am 
Thank you guys for the tip about disabling it through the console! It made the dragon disappear and I was able to talk to Neloth to continue the quest. Although his tower is a mess now with everything knocked off the shelves from the dragon flying around, hopefully that stuff will reset.

As for mods, I only use a couple mods like HD Plants + Flowers, Pure Waters, Lanterns of Skyrim, Sounds of Skyrim, and have the Unofficial Patches installed and sorted. Nothing for gameplay, UI or dragons even so that's what made this dragon a particular mystery to me.
cold.fire Jun 15, 2015 @ 10:49pm 
Damn I just got this exact same bug while playing today! I am using a bunch of mods, but none of the same ones as chealsea! except for the unofficial patches. Very weird bug, but I will try the console disable command and hopefully that solves this extremely odd issue!
Omgwtfbbqkitten Jun 16, 2015 @ 12:07am 
I have just been doing Neloths quests trying to get Whirlwind Cloak, I had to restart everything like a dozen times because i couldn't get the Experimental Subject (B) quest to start and not once in all those attempts did I see a dragon inside.

Now I am disappointed and feel that I was cheated out of a cool close quarters dragon fight.
kenconk Aug 26, 2015 @ 11:04pm 
I had the exact same problem with a "Legendary Dragon" With a combination of destruction spells, it's health went completely down, but it was still flying very fast THROUGH the room. Pushing the console key at random intervals allowed me to see part of the Dragon. I targetted the dragon, and tried "MarkforDelete." That didn't work, but "disable" worked fine. The fight song finally stopped, and I could continue my conversation with Neloth.
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Date Posted: Jun 7, 2014 @ 9:28pm
Posts: 8