Essenji Jul 3 @ 4:55am
Gardener of Men bug
Hey! So I'm stuck on the main quest of the Dragonborn DLC. I was at the point where Hermaeus Mora sends you back to Solstheim to get the Skaal secrets. When I left the book I saw "Follower has left your side" in the top left of the screen. It seems that Frea decided to stay behind in Apocrypha with Hermaeus Mora and she doesn't want to come with me anymore because "Her place is with her people".

When I return to Skaal and talk to Storn it continues the quest just fine. He does his dialogue with Frea (even though she isn't present) and goes to read the book. He is impaled by Hermaeus Mora, but nothing else happens. The quest just gets stuck there without Herma-Mora actually appearing above Skaal (if I've read correctly, that is what should happen).

Has anyone else had this problem happen? I've been trying to google around but I can't seem to find anyone having the exact issue I'm having. Anyone know of a fix?
Thanks in advance!
Showing 1-6 of 6 comments
< >
chrisnc35 Jul 3 @ 5:14am 
Resort to the last auto save, should be when you left Apocrypha. If that doesn't work, log off and reload the auto save again. This might fix it.

Also, you can reload a different character save. Then log off and log on to the original auto save. This also can clear up the temp glitches as well.
Essenji Jul 3 @ 5:16am 
Done all of those, none of them change what happens. Tried the Gardener of Men bugfix, but that didn't do anything (don't think it's the same bug).
mpd1958 Jul 3 @ 5:19am 
Frea shouldn't have traveled to Apocrypha with you in the first place. Only the reader is teleported to that realm, at least that is how it's suppose to work.
Essenji Jul 3 @ 5:23am 
Hmm, strange. My followers followed me there like every time :S Is there a way to teleport her to Skaal by console commands? I'd rather not break the characters by using quest completion things if at all possible.
Uncle64[SwE] Jul 3 @ 5:24am 
You should not come whith you, but i have other follower that have followed. And they got stuck there. I did reload one old save.
Essenji Jul 3 @ 8:57am 
Okay, so I sort of fixed it.
I went back to a save before I left Apocrypha (luckily I had a save just before Herma-Mora by happenstance) and went outside the book with Frea. She followed me out and I then released her from my service.

When I later got to Skaal the quest progressed normally, with Frea taking part in the conversation and Hermaeus Mora appearing above the town.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50