ImSoAw3some Aug 9 @ 5:14pm
Killing Miraak Bug?
When I attack him and he gets to like 30 percent health he teleports to an inaccessible place. I tried killing the dragon whose name starts with an R but Miraak still doesn't come back. I looked up a tutorial on how to kill him and what's different (other than they can actually kill him -.-) is that Miraak starts a dialogue with them. For me, he says something like "we should welcome our new guest" and then when i go over to him he just stands there and if I press E he says "Now is not the time to talk" and then he attacks me. Any help?

Edit: Just to clarify, this is not the normal glitch most people experience where he's unkillable in the center. Like, he literally disappears for me and doesn't come back.
Last edited by ImSoAw3some; Aug 9 @ 5:28pm
Showing 1-3 of 3 comments
< >
Grathagis Aug 9 @ 5:15pm 
Check the UESP wiki or ELDER SCROLLS wiki, perhaps they might help
ImSoAw3some Aug 9 @ 5:19pm 
Originally posted by Grathagis:
Check the UESP wiki or ELDER SCROLLS wiki, perhaps they might help

Checked everywhere, can't seem to find a solution. But I'll keep checking.
ImSoAw3some Aug 9 @ 5:57pm 
I had tried reloading previous saves, but I just reloaded one from a little while ago. I played through and it worked fine. That was odd. Also the fight was pretty easy. I didn't use a single health potion, and I'm level 28.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Aug 9 @ 5:14pm
Posts: 3