Closure > General Discussions > Topic Details
SimonLi2575 Dec 31, 2012 @ 3:09am
Lagging badly
A long time ago, I bought this game, played for a while, and stopped playing it. It was smooth, not much lag has occurred.
Today, I decided to replay this game, but whenever I quit the menu screen, the game lags insanely.
I tried verifying the game files, they successfully validated.
Does anyone know how to fix the problem?
Showing 1-15 of 21 comments
< >
leinad112 Dec 31, 2012 @ 1:42pm 
Lag like, 1 image per second? Same here.... But here only starts after 5 minutes.
unwaveringresolve Dec 31, 2012 @ 2:47pm 
I'm having the same problem as leinad112. Everything is normal for about 5 minutes, and then the framerate drops to about 1 fps. If I quit to the menu and try to reload, the game crashes to a black screen.
[GER] ✘Ducal✘ Dec 31, 2012 @ 4:12pm 
I have the same problem after ca. 5 min playtime.
http://www7.pic-upload.de/01.01.13/ovgx6rz168.png
on the picture you see when it starts to lagging
Last edited by [GER] ✘Ducal✘; Dec 31, 2012 @ 4:15pm
mandragorae Jan 1, 2013 @ 9:38am 
For me, it's taking about 5 minutes before I hit the lag wall.
Specs [680i chipset, C2Q Q6600, 4G DDR2, GTX 680 2G GDDR5, W7-64]
I am about to apply the beta patch, and am available for testing.
EDIT: applied patch. Now that I take a close look at the time: it's 4 minutes till slowdown. This is confirmed from a couple of tests. About 4 minutes each time.
A note of interest: GPU is almost idling, and graphic memory reports only about 250MB used.
Last edited by mandragorae; Jan 1, 2013 @ 10:18am
mandragorae Jan 1, 2013 @ 10:45am 
Update: now got a crash from closure.exe after completing a level (the slow way).
Some impression: it feels like there is a link between the input and the game slowing. Walking is painful because pressing left or right continuously yields the same effect as pressing it repeatedly; jumping ends up giving a very low jump like pressing then releasing immediately "jump". Sure, it might just be the executable having some difficulty processing the keypresses correctly. (my 2c worth)
Glaiel Gamer  [developer] Jan 1, 2013 @ 12:11pm 
if you go reduce key repeat rate in control panel does it help at all? If it does then its related to input.
mandragorae Jan 1, 2013 @ 1:32pm 
Nah. Besides, the problem happens after 4 minutes almost always exacly 4 minutes. I simply noticed that when slow-down happens, the game seems to mis-interpret keypresses
leinad112 Jan 1, 2013 @ 5:08pm 
When I try to go to the menu and reload the game (after the deadly 4 minutes @ 1fps), I get this error and the game shuts down: http://img19.imageshack.us/img19/9444/errordqb.png
It's a shame, because the game looks realy good.
[GER] ✘Ducal✘ Jan 2, 2013 @ 6:22pm 
Originally posted by Glaiel Gamer:
if you go reduce key repeat rate in control panel does it help at all? If it does then its related to input.
it doesn´t works
mandragorae Jan 2, 2013 @ 7:18pm 
Yes the game is interesting; it's quite apart from everything else I saw. So you are right on that one. BUT we have a problem. Could you guys please post your specs? There has to be a common between all of us. Let's find it, and help Glaiel make a partch so we can all enjoy this game.
leinad112 Jan 2, 2013 @ 7:40pm 
Originally posted by mandragorae:
Yes the game is interesting; it's quite apart from everything else I saw. So you are right on that one. BUT we have a problem. Could you guys please post your specs? There has to be a common between all of us. Let's find it, and help Glaiel make a partch so we can all enjoy this game.

AMD Phenom II 3.2Ghz, 2x4Gb DDR3, Radeon HD5770, Windows 8 64b. Completely different from yours....

I signed for the beta, in the steam/game option, but the problem remains.
[GER] ✘Ducal✘ Jan 3, 2013 @ 6:49am 
Originally posted by mandragorae:
Yes the game is interesting; it's quite apart from everything else I saw. So you are right on that one. BUT we have a problem. Could you guys please post your specs? There has to be a common between all of us. Let's find it, and help Glaiel make a partch so we can all enjoy this game.

AMD FX-6100 3,3GHz, 2x4Gb DDR3 1333, GTX560, Win 8 64bit
frozenray02 Jan 5, 2013 @ 6:48pm 
Pentium G840 2.80Ghz, 2x4Gb DDR3 1333, GTX560ti, Win 7 64bit (lags with beta patch still)
Thomn Feb 21, 2013 @ 5:34am 
Same problem here, on a mid-2009 13' Macbook Pro.
{SOLID}♣{Donegal Danny}♣ May 5, 2013 @ 6:00pm 
Same here. My PC is a mighty beast but this little game lags so bad that its UNPLAYABLE. Mine starts right away though, it doesnt wait for a 4 or 5 min mark to lag. It lags as soon as I start the game :(
Showing 1-15 of 21 comments
< >
Per page: 15 30 50