View Stats:
Closure > General Discussions > Topic Details
Glaiel  [developer] Dec 13, 2012 @ 12:08am
Patch test
Working on a patch, if you want to see if it worked OK right click Closure in your library, select Properties, select Betas, and opt into the public patch beta

The beta only works for windows right now, mac users will get the current build

Looking to test this on anyone who has an intel HD integrated graphics card

current changelog (I'm still working on stuff)
- misc bugfixes
- bugfix with CRT monitors that don't report dimensions

- 3 new options in settings.cfg:
- #texmaxsize- limits the size of render textures, originally had no limit, now is set to limit to 4096x4096, curious if this helps on integrated graphics cards
- #savefilename- the name of the save file, you can change this to create a new save file
- #weather- an option to disable all weather effects

there's some other things I've been working on but those can be a surprise later

What I want to know
does this help with any of the problems on integrated graphics? does fiddling with the new settings help it run on integrated graphics? does the patch install correctly?
Last edited by Glaiel; Dec 13, 2012 @ 12:09am
< >
Showing 1-15 of 52 comments
Winchester_z Dec 14, 2012 @ 1:38pm 
Waiting for it Ty.
scag-lion Dec 17, 2012 @ 5:17pm 
Not to sure it installed correctly. I don't get any extra things than there were before under the options menu. Cool to see your working on a patch anyways.
Glaiel  [developer] Dec 17, 2012 @ 7:00pm 
they aren't in the options menu they're in the settings.cfg in the game's data folder
scag-lion Dec 19, 2012 @ 2:40pm 
It works!
I just had to turn of the weather effects.
El Torso Dec 20, 2012 @ 2:44am 
Hello Tyler,

Unfortunately, playing around with these settings did nothing for me. The game still lags horribly after the title screen.

Anyway, glad you're working on fixing this !

[EDIT] Sorry, I just noticed you were looking for people with an Intel HD card, which is not my case.
Last edited by El Torso; Dec 20, 2012 @ 3:34am
Winchester_z Dec 21, 2012 @ 8:41am 
I have a Intel HD card and AMD raedon card , and the game runs ok
🐾Reb Pamba🐾 Dec 22, 2012 @ 12:32pm 
I tried the beta and I was able to get the game to play. However, there is an issue where pre-rendered textures remain visible and simply shift to the left. This causes me to see repeats of the character I'm playing as, as well as the environment that I'm not supposed to be able to see. I'm falling in pits because I can't see where is actually illuminated and where is simply glitching.

[edit] I attempted adjusting the #texsizemax to see if that helped with the rendering, and it did not. Wondering if removing this option entirely will fix it.
Last edited by 🐾Reb Pamba🐾; Dec 22, 2012 @ 12:37pm
foomojive Dec 22, 2012 @ 2:20pm 
I have the same problem as Red Note above. I turned off weather. Here is a screenshot: Ghosting of everywhere I've been. I have an Intel HD graphics card. More info on request.
Last edited by foomojive; Dec 22, 2012 @ 2:20pm
Inunah Dec 23, 2012 @ 9:58am 
Well now I can see things, but the 1fps framerate makes it completely unplayable and there's ghosting.
Last edited by Inunah; Dec 23, 2012 @ 10:49am
Stevoisiak Dec 23, 2012 @ 11:57am 
I have an intel HD card, so I can test it. Just give me a minute.
Stevoisiak Dec 23, 2012 @ 12:38pm 
I just tried it. Nothing changed with the beta patch. I still fall off the level
Last edited by Stevoisiak; Dec 23, 2012 @ 12:43pm
Winchester_z Dec 23, 2012 @ 12:50pm 
Originally posted by Stevoisiak:
I just tried it. Nothing changed with the beta patch. I still fall off the level
i have the same problem, falling
Stevoisiak Dec 23, 2012 @ 5:13pm 
I may have an idea to fix the infinite falling bug on integrated graphics cards.

I've played through most of chapters 2 and 3, and can confirm that the bug does not occur on those levels. Maybe just add a miniature light source under the platform where you start in chapter 1 so that you dont fall off if there is no light there?
Glaiel  [developer] Dec 24, 2012 @ 11:36am 
I could but if that bug is happening its a sign of worse problems than just that, and since I can't reproduce it I have no idea what the other problems it causes are (more unfair jumps, losing boxes easier, etc) and I'd rather people not play a game that "feels off" for technical reasons

if you set the #fps and #speed in settings.cfg to like, 10, does it still occur?
Glaiel  [developer] Dec 24, 2012 @ 11:43am 
the issue is that its rendering the spotlights slightly too dark. The shaders for the game are compiled from source, and I do include those in the resources for the game. I don't have any guarantees for how this effects the game, but the blur on spotlights is in Resources/shaders/ and Resources/shaders/ You can open them in a text editor. Each of these has a line that looks like

sum *= 1.0/46.0;

try changing it to like

sum *= 1.1/46.0;

to make the spotlights around 10% brighter (i think) which might help (make backups of the files first)
< >
Showing 1-15 of 52 comments
Per page: 15 30 50

Closure > General Discussions > Topic Details