Closure

Closure

View Stats:
Closure > General Discussions > Topic Details
 This topic has been pinned, so it's probably important
Glaiel  [developer] Oct 24, 2013 @ 12:00pm
OSX 10.9- FIXED
Updated the game to work on OSX 10.9 Mavericks. Let me know if it worked for you / broke it for any other machines.

IF YOU GET A BLACK SCREEN- disable steam overlay [or start the game by hitting enter, then mash enter over and over to pause/unpause till the game shows up. this can work sometimes]
Last edited by Glaiel; Oct 30, 2013 @ 1:30pm
< >
Showing 1-15 of 29 comments
Glaiel  [developer] Oct 24, 2013 @ 8:32pm 
[removed- workaround no longer necessary]
Last edited by Glaiel; Oct 30, 2013 @ 1:29pm
Stelios Oct 29, 2013 @ 2:55pm 
It crashes on my Mac (Mavericks 10.9) too. At first it asked me to install x11 which I did, but when I launched it later again I got an error report.
Glaiel  [developer] Oct 29, 2013 @ 3:21pm 
yeah I know, i'm still researching some solutions. It seems to have effected other games in a similar way too.
Stelios Oct 29, 2013 @ 3:36pm 
Ok, no problem. Good luck and good bug hunting. Just let us know when you ll have an update ready. cheers.
Glaiel  [developer] Oct 30, 2013 @ 1:32pm 
Should be fixed
Stelios Oct 30, 2013 @ 2:05pm 
Yes it works, thanks.
Adrian1369 Oct 30, 2013 @ 4:17pm 
Could you please update to to run native on Mac , I mean the most recent version (Lion , Mounain Lion , Mavericks ) why should I install roseta .
Glaiel  [developer] Oct 30, 2013 @ 4:19pm 
you shouldn't need to install rosetta
szhorvat Nov 1, 2013 @ 12:13pm 
Now it does work on Mavericks, but the issue on Macs with switchable graphics is still present:

Some Mac laptops have two GPUs (Intel and NVIDIA), and automatically switch between the two. If at the point when Closure starts, the machine is using the Intel GPU, the game will start in low resolution but will draw everything in large size, and only show a corner of the display area (the rest is cropped off). I need to manually switch the computer to NVIDIA graphics, and then it works correctly.

I would expect the game to trigger switching to NVIDIA automatically, like other programs do.
Adrian1369 Nov 2, 2013 @ 12:52pm 
Then why when I try to start the game it asks to install Xserve (rosetta)
Glaiel  [developer] Nov 2, 2013 @ 12:55pm 
It should be asking about XQuartz http://xquartz.macosforge.org/landing/ which isn't the same thing as rosetta
Adrian1369 Nov 7, 2013 @ 3:38am 
The why should i install XQuartz
For The Watch! Nov 12, 2013 @ 2:58pm 
This happens on my PC all the time. Literally tried the game for the first time today and it happens every time. Barely made it past the third screen (with credits and title). Disappointed as this is the only game on a brand new system to do it. Surely this is an established bug and should be fixed by now?
rhywun Nov 30, 2013 @ 9:42am 
Does not work for me on Mavericks, after installing XQuartz and rebooting. Still receive error "Thread 1 crashed".

PS. I don't see any update - the game file modified date is still September 2012.
Last edited by rhywun; Nov 30, 2013 @ 9:46am
Glaiel  [developer] Nov 30, 2013 @ 10:57am 
verify the integrity of the game cache to force it to update, or delete it and reinstall
Last edited by Glaiel; Nov 30, 2013 @ 10:57am
< >
Showing 1-15 of 29 comments
Per page: 15 30 50

Closure > General Discussions > Topic Details