laseragna Nov 26, 2012 @ 6:06pm
Optimus Fix not working
I just picked up Generations recently, and noticed the Configuration Tool won't recognize my video card. I'm running on a laptop, with an NVIDIA 640M, Intel i7, and 6 GB RAM. So I researched what was going on, and found out about the troubles with Optimus. So I found the workaround solution(NVIDIA Control Panel, Screen Resoltion, detect VGA, etc.), I tried it, it didn't work, it just gave me the Error that my Config settings were different from my hardware. I've reinstalled the game 4 times, tried the workaround, kept getting the problem.

I did read somewhere that the new NVIDIA drivers have fixed it, but I alt+tab out(this is when I haven't touched any of the settings in the Config Tool or NVIDIA Control Panel) and check for activity on my NVIDIA GPU in my taskbar and it says there is none. So unless it secretly is running with neither programs set to it, and my Activity not sensing it, I'm really stumped.
Showing 1-8 of 8 comments
< >
laseragna Nov 26, 2012 @ 6:10pm 
I should add that when I run on default settings, it runs ok(when it runs on my Intel 4000, at least I think it is). It has some troubles on high settings though.
BooleanCheese Nov 26, 2012 @ 6:21pm 
Same issue here. I tried going into the Nvida control panel and choosing to run the configuration tool and the game with the graphics card (geforce gt 650M for me) rather than "auto-select", but the configuration tool still wouldn't recognize the graphics card and I couldn't for the game to run with it because my hardware doesn't match the configuration file.

The game runs fine on the default settings, but I'd like to use my graphics card so I can run it at 1920x1080.
laseragna Nov 26, 2012 @ 7:04pm 
The workaround method I mentioned is this:

1 ) Open your NVIDIA Control Panel(By right clicking on the desktop and selecting the "NVIDIA Control Panel")

2 ) On the 3D Settings List, Chose "Manage 3D Settings"

3 ) On the "Program Settings" tab, add the SonicGenerations.exe and ConfigurationTool.exe in your installation folder, then force both of them to use the High Performance NVIDIA processor. (Don't forget to apply the changes)

4 ) Open your "Screen Resolution" window (By right clicking on the desktop and selecting "Screen Resolution").

5 ) Click Detect

6 ) It should display additional monitors greyed out and saying "Another display not detected". Find the one that is not Intel Integrated Graphics but your High Performance NVIDIA Graphics (Whichever it is) and select it.

7 ) On the "Multiple displays", chose "Try to connect anyway on: VGA" (it can be another slot depending on your hardware).

8 ) Apply.

9 ) Again on the "Multiple dislpays", chose "Extend these displays".

10 ) Run the ConfigurationTool.exe, it should show your NVIDIA graphics card as a graphics adapter.

11 ) Select your main display which is Intel Integrated Graphics. (Do NOT select your NVIDIA card!!! Because it is not associated with a monitor.)

12 ) Run the game normally. It should work fine now.
SKIDROW Nov 27, 2012 @ 12:03am 
IT DOESNT PLEASE HELP!
Guregori Nov 28, 2012 @ 10:51am 
http://forums.steampowered.com/forums/showpost.php?p=29595554&postcount=87
This worked for me. Getting the name of the card exactly right is important - at first it didn't work, because I didn't put right the amount of spaces in GraphicsConfig.cfg.
laseragna Nov 30, 2012 @ 9:41am 
Thanks for your reply Guregori, I tried what you posted, but it still didn't work. I have my Control Panel set to the NVIDIA, I copied my card name straight from the device manager so I have the number spaces after it correct, I deleted the second from last line in the Config, switched my display number in the Config from 0, 1, and 2 and tried each number while using the desktop extend trick and without it. I'll re-install later and try again, I guess...
The Queen Valene May 18, 2013 @ 6:36pm 
Originally posted by laseragna:
The workaround method I mentioned is this:

1 ) Open your NVIDIA Control Panel(By right clicking on the desktop and selecting the "NVIDIA Control Panel")

2 ) On the 3D Settings List, Chose "Manage 3D Settings"

3 ) On the "Program Settings" tab, add the SonicGenerations.exe and ConfigurationTool.exe in your installation folder, then force both of them to use the High Performance NVIDIA processor. (Don't forget to apply the changes)

4 ) Open your "Screen Resolution" window (By right clicking on the desktop and selecting "Screen Resolution").

5 ) Click Detect

6 ) It should display additional monitors greyed out and saying "Another display not detected". Find the one that is not Intel Integrated Graphics but your High Performance NVIDIA Graphics (Whichever it is) and select it.

7 ) On the "Multiple displays", chose "Try to connect anyway on: VGA" (it can be another slot depending on your hardware).

8 ) Apply.

9 ) Again on the "Multiple dislpays", chose "Extend these displays".

10 ) Run the ConfigurationTool.exe, it should show your NVIDIA graphics card as a graphics adapter.

11 ) Select your main display which is Intel Integrated Graphics. (Do NOT select your NVIDIA card!!! Because it is not associated with a monitor.)

12 ) Run the game normally. It should work fine now.

The game will work :) but on Intel HD4000/Nvidia (630m My case) and still lags as ♥♥♥♥
Dodino Jul 16, 2013 @ 2:10am 
I have solved the issue:

1- update sonic generations to version 4
2- run configtool (SETUP it to run with nvidia graphics from NVIDIA ControlPanel)
3- set everything as you want (but leaving INTEL HD as graphic)
4- save and exit configtool
5- Go to the Sonic Generations directory (in most cases "C:\Program Files (x86)\Steam\steamapps\common\sonic generations") and open GraphicsConfig.cfg in notepad or your preferred text editing software.

6- You should notice that the second line will be the name of your Intel adapter. Replace this with the name of your NVIDIA adapter exactly as it appeared in Device Manager. To do so enter into "details" and copy the name. It may contain spaces also (after the name) that matter!

7- You should see a line that says something like "MONITOR\LGD0292\{4d36e96e-e325-11ce-bfc1-08002be10318}\ 0000" (this will vary depending on your exact setup, just look for line of this format), it should be the second to last line. Delete the contents of this line completely so you are left with a blank line. Here is my configuration file as an example:

Quote:
----
Do not manually edit this file, use the configuration tool.
NVIDIA GeForce GT 555M
\\.\DISPLAY1
1600.900.60
1
1
1
1
0
d7b78e66-4256-11cf-fd56-b424b7c2c535

1515474505
----

8- run the game with Nvidia graphic card (SETUP from Nvidia CP like configtool)



REMEMBER THE PART OF UPDATING SONIC GENERATIONS TO V4 IS ESSENTIAL, without this nothing works!!
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Nov 26, 2012 @ 6:06pm
Posts: 8