Leon Nov 8, 2012 @ 9:12am
Help Controller doesnt work
´Hi I have the game for some months now and played via keaboard so it wasnt that good now I got a Original Xbox 360 controller for PC and it doesnt work!
When I play the game without the controller its the same as before but when I start it with the controller plugged in its extremely slow the title needs like 2 minutes to go away and when i finally get in the menu the controller doesnt work and I still have to use the keyboard
Showing 1-10 of 10 comments
< >
Inso Nov 8, 2012 @ 10:58am 
When you open the configuration menu (start the game via steam, then choose configuration instead of play), can you see the controller in the devices-tab? (first one)
Additional: which driver do you use, which OS do you have, does the controller function properly in other games, have you tried a different USB port, have you tried to unplug other USB-devices (wheel ect)?
Leon Nov 8, 2012 @ 11:01am 
yes the game sees the controller in the configuration menu

yes the controller works well in other games like Dark SoulsI tried several usb ports and have no other usb things in right now
Inso Nov 8, 2012 @ 11:06am 
Hmm have you checked your device manager, are any "?" devices there which could cause delay/lag? Maybe let steam check your gamefiles aswell (right click game in list, properties..)
Leon Nov 8, 2012 @ 11:30am 
no ? devices in the manager

I cant find anything like check gamefiles where in properties is it supposed to be
Inso Nov 8, 2012 @ 11:38am 
(My button names are translated, so maybe the name differs slightly from the name I write)
Right-klick SG in the game list, choose properties (last option in the list), choose the third tab (local data) and press the thirt button (check gamedata for errors), then steam should re-check all game files.
Leon Nov 8, 2012 @ 11:41am 
ok nevermin i found it some days ago i tried the game with another controller not official 360 but it didnt work well so i put a 360 emulator thing in which was still in and completely forgotten by me

deleted it and now it works
Eggmanronpa Nov 11, 2012 @ 10:59am 
I hit the same problem. The configure screen oddly likes to load twice, and it doesn't pick up my controller in the game despite picking it up in the configure options.

I have an "Unknown Device" which I disabled. Game still gives me problems. Should I delete/reinstall?
shrek 6 shrek goes to hogwarts Nov 17, 2012 @ 8:50am 
Try downloading x360ce and putting it in your game folder, and configuring your controller with that.
Cheese Sandwich Nov 23, 2012 @ 4:25pm 
Insert reciever usb, find usb(Unknown device) in device manager, choose Microsoft xbox360, you're done, turn on the controller, play.
Gru Jun 18, 2013 @ 1:59pm 
Had this problem too.. >_<

What fixed it was:
Download and put x360ce in Sonic Generations steam folder and launch it
For it updated some files and everything finally works!

also earlier I downloaded and put 2 files un that same folder.. don't know if that's needed.
msvcp110.dll
and
msvcr110.all

GL!
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Nov 8, 2012 @ 9:12am
Posts: 10