"The detected configuration does not match your current hardware. Please re-run the configuration tool."
I've configured the game, and everything is correct. What am I supposed to do to fix this? (I guess this is what I get for trying to play the stupid port of this)
Showing 1-11 of 11 comments
< >
Darb Jul 24, 2013 @ 6:38pm 
Omg I've been having the same problem lately, it makes no sense since the game used to work fine before. It's not a horrible port since it runs so smooth and looks great when it works, but this and the online not working is so frustrating.
Draknon Jul 24, 2013 @ 7:14pm 
I am getting this same error
OK, what you need to do is uninstall the game, then delete the Sonic Generations folder from your common folder in steamapps. Whenever you uninstall the games it leaves that behind. This is how I fixed it.
PlanPony Jul 25, 2013 @ 1:46pm 
i only deleted the config files in Program Files\Steam\steamapps\common\sonic generations if u look in and delete only files with CFG File like statsConfig for example i thing theres only 3, then try starting game again
Stooball Jul 25, 2013 @ 4:22pm 
Thanks PlanPony, that did the trick for me. I just went in to where you stated, Program Files(x86)\Steam\steamapps\common\sonic generations and deleted all the .CFG files. I had four of them.

When I started the game up again, it just told me to configure. After that, it worked fine. Thanks again!
Shropt Jul 28, 2013 @ 8:29am 
PlanPony's fix worked for me too. Thanks!
H3X3N Aug 21, 2013 @ 7:27pm 
Well, trick worked great for me too. Thanx much ^_^
m3c1dilk Aug 22, 2013 @ 9:39am 
I tried to do it on the demo but it still doesnt work.
tracybowman94 Aug 23, 2013 @ 7:01pm 
I am having this problem as well. Anybody know what to do?
Tjwalker =) Aug 26, 2013 @ 11:57pm 
I just made a post on the steps to take to fix that error. It should work. If not, then the .cgf files itself aren't the only problem.

Here's the other steps that you need to take if deleting the .cgf file doesn't work alone:

1) Click "Play" on Sonic Generations in the Library and the click "Configure"

2) Click "Graphics Configurations"

3) I noticed that all the quality settings was on "Low". Set both the Shadow Quality and Reflection Quality on "High"

4) Make the Configuration window full screen so you can click the "Save and Exit" button at the bottom

5) Run Sonic Generations

Did it work now?
Last edited by Tjwalker =); Aug 26, 2013 @ 11:57pm
Lil-G-Gamegenuis Sep 10, 2013 @ 7:05pm 
i know how to fix it. first reinstall sonic generations (if you modded it in any way)
2nd download the demo
3rd run the demo once to make sure it works
4th copy the demo's files but click "let me chose which files" or something like that
5th keep the full's main game exe, and the cpk files
6th spread the word
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Jul 24, 2013 @ 1:24pm
Posts: 11