DC | alvarosave [CD] Dec 23, 2012 @ 4:05am
Sonic Generations Won't Start Up
Whenever I try to play Sonic Generations a blank pop-up box comes up (the game is still loading and has a black screen) and the only option is to click accept. Once I do so, the game quits. I don't know what is wrong since it used to work but now it doesn't, without any changes being made to my computer. Please help, I've payed for this game when it came out and it ♥♥♥♥es me off that I can't play it =/. BTW, uninstall-reinstall, and replacing the cache files won't work. Also tried restarting my computer various times and running on windowed mode.
Last edited by DC | alvarosave [CD]; Dec 24, 2012 @ 7:01pm
Showing 1-15 of 28 comments
< >
HKnuts Dec 24, 2012 @ 6:36pm 
Can you make a screenshot of the "only option is to click accept" part?
HKnuts Dec 24, 2012 @ 7:26pm 
Ok that's quite literally exactly how you described it. I was expecting at least an ingame interface. Hmz. You could try veryifying the game cache. Otherwise I've found this: http://segmentnext.com/2011/11/04/sonic-generations-crashes-stuttering-fps-freezes-and-fixes/
Numbers 9 and 10 may apply to you, but I'm not sure.
DC | alvarosave [CD] Dec 24, 2012 @ 8:47pm 
Tried them out both, thanks for your help but they both failed =(
Palcomix Dec 25, 2012 @ 3:34pm 
got the same problem, the game was working fine just days ago, but now i only get a blank window and it never starts... i wonder if have to do with the casinolights dlc i bought yesterday
Palcomix Dec 25, 2012 @ 3:37pm 
my theory is this, the video driver (catalyst?) updated today..
valrond Dec 30, 2012 @ 1:01pm 
had the same problem, deleted the graphics.cfg file on the sonic folder under steamapps/common and it works
DC | alvarosave [CD] Dec 30, 2012 @ 1:38pm 
ty, I tried it but it failed as well =( I've contacted sega at this point.
HKnuts Dec 30, 2012 @ 8:27pm 
Good luck
SrMilagro / Milah Jan 9, 2013 @ 8:43am 
I had same problem, game works ok few day ago and now i have that blank pop-up. Maybe new nvidia drivers?. I deleted graphics.cfg and when i checked the configutation i c everything on low, try to start the game and dint work. I put all on high and game start :D. Srry for my bad english, hope this help.
DC | alvarosave [CD] Jan 9, 2013 @ 11:43am 
I've contacted support alrdy :P they're even having trouble with this
jasmine-karen Jan 9, 2013 @ 6:13pm 
Guys, I was pretty sure that I was alone. I'm new to Steam and I purchased the game yesterday and now it will not play. Before the mystery of the unknown loading issue, I tried modding SG and running it with SonicGMI and it did not work at all. Unistalled any additions, and tried running the game normal, did not work. Unistalled the game and re-installed the game, and yes you guessed it, it did not work. I would get a blank screen and then it would just go back to Steam Client screen. This really sucks. In a little over 24 hrs, I've lost $29.99 I think, unless someone knows of a remedy besides my waiting on a response from Steam on this issue.
Last edited by jasmine-karen; Jan 9, 2013 @ 6:13pm
HKnuts Jan 9, 2013 @ 6:37pm 
I know it's an extensive process, but has anyone tried removing everything? I'm talking deinstalling Sonic Generations and Steam, manually clearing out any leftover folders, and reinstalling the whole thing?
DC | alvarosave [CD] Jan 9, 2013 @ 7:15pm 
Guys, don't worry, like I said, I've contacted support. When I get to a proper solution, I'll post it here =). For now, updating your drivers works for some people. And nah, reinstalling the whole thing won't work, nor eliminating any files.
jasmine-karen Jan 10, 2013 @ 2:17pm 
Thanks "alvarosave" I really hope a solution comes through the Steam pipe. My drivers are all updated. Yet Steam is saying that my drivers are out of date and can't determine which ones. I will look into it myself and see what drivers maybe a cause to this problem.
Showing 1-15 of 28 comments
< >
Per page: 15 30 50