Sonic Generations

Sonic Generations

View Stats:
>w> Dec 5, 2012 @ 11:12am
"MSVCP100.dll is missing from your computer."
Okay, so I downoaded the software that supposedly has the dll, Microsoft Visual Studio whatever, did a registry clean and reinstalled Sonic and nothing changed.

Any other possible remedies?
< >
Showing 1-15 of 19 comments
MNKyDeth Dec 6, 2012 @ 4:59am 
Having the same problem here. I Downloaded the msvcp100.dll file manually and put it in the game directory and also in my system32 folder. It made no difference.

Hopefully someone comes along and helps us out...
Lipe.x.rock Dec 7, 2012 @ 4:59am 
I had this same problem when I installed. download the dll that will work
<e$k> bb Dec 7, 2012 @ 6:56am 
Install the x86 and the x64 version of visual c++ 2010
>w> Dec 7, 2012 @ 2:06pm 
Originally posted by Lipe Vasconcelos:
I had this same problem when I installed. download the dll that will work
I did that and nothing changed.

Originally posted by <e$k> bb:
Install the x86 and the x64 version of visual c++ 2010
I'll try this, thank you.
Last edited by >w>; Dec 7, 2012 @ 2:06pm
Icy1007 Dec 8, 2012 @ 9:00pm 
Install the Redistributable of Visual C++ 2010. It should have been installed when you first started the game.
Last edited by Icy1007; Dec 8, 2012 @ 9:01pm
Ninjago.Kai Dec 8, 2012 @ 9:38pm 
try this..... not sure if it will work but it did make all my company of heroes working ... try verifying game cache
>w> Dec 9, 2012 @ 7:35pm 
Originally posted by Icy1007:
Install the Redistributable of Visual C++ 2010. It should have been installed when you first started the game.
Nothing changes when I do that, it still says that the dll is missing.
jordan_23xx Dec 9, 2012 @ 7:59pm 
I'm having the same problem tried everything.I have MSVCP100.dll in SYSTEM32 but the game still dosent work. bought this last night and still cant play.
>w> Dec 10, 2012 @ 8:53pm 
Does SEGA even read these forums?
jordan_23xx Dec 10, 2012 @ 10:48pm 
Dose anyone else have this problem??? All of my other games work fine. I have all of the Microsoft visuals C++ 2005,2008 and 2010. the MSVCP100.dll file is in my computer, But sonic is just not finding it. I have re installed Sonic several times, checked the file cache several times. I have goggled for hours but nothing PLEASE HELP
Last edited by jordan_23xx; Dec 10, 2012 @ 10:50pm
jordan_23xx Dec 10, 2012 @ 11:17pm 
I just fixed it Finally. So what i did was download all of Microsoft Visual C++ installed in both 32bit and 64bit. but the main one i think in needed was Microsoft visual C++ redistributable 2010 (x86) 32bit. then i had to go to windows update and update all of them.
let me know if it worked for you >w>
I contacted SEGA about it so they will send a patch so be ready to play... at some point
Xenostic Dec 31, 2012 @ 5:23am 
Originally posted by jordan_23xx:
I just fixed it Finally. So what i did was download all of Microsoft Visual C++ installed in both 32bit and 64bit. but the main one i think in needed was Microsoft visual C++ redistributable 2010 (x86) 32bit. then i had to go to windows update and update all of them.
let me know if it worked for you >w>
nvm about the new one but were can i download the stuff?
Oops, I created a thread on this issue a few months late. Should've kept reading the forums. Is it possible to not have Microsoft Visual whatever the heck?
Okay, so I did the Microsoft Visual Studio crap, but it still did not work. Then I figured out that my Vista only supportsl the x86, so I downloaded that. I then branched from the initial install page and went to the link for the x86 2010 edition at the bottom of the page. Now it works. One must update the Visual studio crap and navigate through more of Microsoft's stupid website to get what ya need. Stupid, but at least I can play Sonic Generations now.
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: Dec 5, 2012 @ 11:12am
Posts: 19