ZIO Jan 10 @ 9:18pm
I'm having performance issues with this game. What could be the issue?
I have a new laptop. It's got an nvidia GT750M. I also have 8 gigs of ram and an i7-4700MQ.

I would think this sytem could handle the game. But There's hiccups. Sometimes it freezes. There was a case when the application completely shut down noting it had encountered some kind of problem. And not, most notably, after a few minutes of gameplay, a prompt shows up saying that the application is taking of too much memory and should be closed.

I don't understand. Can't anyone tell me what's going on?
Showing 1-6 of 6 comments
< >
ZIO Jan 11 @ 7:32pm 
No one have anything to say? The game isn't even recognizing the nvidia graphics card and instead is operating under the intel i7. Like, what gives?
infamous'Cynic Jan 15 @ 5:52pm 
Have you tried forcing your computer to use your nvidia graphic card?
Make sure your charger is plug in.
Go to your nvidia control panel.
Go To Manage 3D settings. Click Program settings.
Look for the Sonic Generations exe. If it's not there, add it by clicking the add button.
Make sure it's using "High preforamance Nvidia processor.
Also, scroll down and look for the power management mode. Make sure it's on "Prefer maximun preforance".

Furthemore, go to your global settings. If it's on AUTO-select, change it to "high-preforance Nvidia Procesor". That auto select rarely works for me. I usually have to manually put it myself.

That should fix your lag problem and the game should use your graphic card.

I have the same problems. My laptop has a i7 with 760M. It won't use my graphic card unless I force it to by using Nvidia Control Panel.

Let me know if it fixed your problem.
ZIO Jan 16 @ 10:18am 
Well, I feel that happened to adjust my concerns for the better.

Although, there are still periods when the game just flat out stops for full seconds at a time, but framerate isn't a concern.

Now I'm not sure whether these pauses are due to the software, or due to hardware.

But thanks for this. I do appreciate it.
infamous'Cynic Jan 16 @ 12:36pm 
Try forcing Tripple buffering? Some other user had the same problem.
My game has the same problem as it drops to 20 for no reason. It's not a good port. :(
ZIO Jan 17 @ 8:32am 
That seemed to have done the trick. Although it still happened, it is so infrequent, I hardly notice it.

Thanks. I appreciate you help alot.
infamous'Cynic Jan 17 @ 7:33pm 
Call I can recommend is you use the Unleash shaders has it improves preforance, sigificantly.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50