Fedor uh Choo Feb 18 @ 4:26pm
I need help! Sonic Generations running extremely slow, but not lag?
Hello everyone,
A few hours ago, I played Sonic Generations with the Overpowered mod. As I went on City Escape (with Sonic Heroes) in the background, as soon as I got off my board, it started slowing down extremely. I'm not sure what kind of lag this is, if it even is lag, but I can open and close the Steam Overlay (with Shift+Tab) just fine; that's not slow at all. I checked to see if it was the Overpowered mod doing that, and it wasn't. I even used Steam to start the game (I use SonicGMI), but nothing could work! I tried posting this on the forums but I was in some queue until I could post a thread
Before this, my Sonic Generations worked perfectly fine with mods like the Overpowered Mod, Shadow Mod, Super Sonic Mod, Unleashed Project, and a small one (startup remover, takes me straight to the title screen when I start the game up). Help!
Computer Specs:
Operating System: Windows 8 Pro 64-bit (6.2, Build 9200)
System Manufacturer: ASUSTeK Computer INC.
System Model: G71GX
Processor: Intel(R) Core(TM)2 Duo CPU P8700 @ 2.53 GHz (2 CPUs), ~2.5GHz
Memory: 6144MB RAM
DirectX Version: DirectX 11

Using NVIDA GeForce GTX 260M

I have played multiple different Steam Games, all of them have worked great; Team Fortress 2, Garry's Mod, Left 4 Dead 2, Scribblenauts Unlimited, etc.

UPDATE: I have tried playing a Unity 3D game on Google Chrome (Attack on Titan Tribute Game), and that was running at 5 FPS when it usually runs at 60. I have also tried three YouTube videos, not lagging as bad but still lagging. It seems that also my typing is lagging too. Would I need serious help?

UPDATE 2: The Unity 3D game and YouTube have stopped lagging, and so has my typing. However, Sonic Generations still fails to start up correctly. Still laggy... Even changing it to High Priority in the Task Manager doesn't help like it usually does.
Last edited by Fedor uh Choo; Feb 18 @ 5:15pm
Date Posted: Feb 18 @ 4:26pm
Posts: 0