Star Ruler > General Discussions > Topic Details
Umbral Reaver Sep 7, 2012 @ 3:56am
Star Ruler does not start
I click play and nothing happens.

Tried again using the application in the folder.

"The application was unable to start correctly (0xc000007b). Click OK to close the application."

Developer Edit:
Please run oalinst.exe where Star Ruler is located. If that doesn't work, copy OpenAL32.dll from Windows/System32 to alongside StarRuler.exe
Last edited by Thy Reaper; Oct 8 @ 5:25pm
Showing 1-15 of 80 comments
< >
Thy Reaper  [developer] Sep 7, 2012 @ 11:05am 
Please run oalinst.exe where Star Ruler is located. If that doesn't work, copy OpenAL32.dll from Windows/System32 to alongside StarRuler.exe
ewfs325 Sep 9, 2012 @ 1:14am 
i cant find my ♥♥♥♥ing Star ruler files any were on my compter to move that file
Dark Mandalore Sep 10, 2012 @ 5:56pm 
OpenAL32.dll does not exist on my computer nor does that installer. When I get a game I expect all the required files for it to run to be included in the install. And yes, I've tried reinstalling the game multiple times.
Last edited by Dark Mandalore; Sep 10, 2012 @ 6:00pm
Thy Reaper  [developer] Sep 11, 2012 @ 11:13am 
They should be in C:\Program FIles (x86)\Steam\steamapps\Common\Star Ruler (depending on where you installed steam).
Thy Reaper  [developer] Sep 11, 2012 @ 11:14am 
Originally posted by Dark Mandalore:
OpenAL32.dll does not exist on my computer nor does that installer. When I get a game I expect all the required files for it to run to be included in the install. And yes, I've tried reinstalling the game multiple times.

Unfortunately, something in Steam's installer steps is configured wrong with OpenAL. It is not just our game, other titles I've purchased on Steam that make used of OpenAL have the same fault as we do.
Firgof Umbra  [developer] Sep 11, 2012 @ 11:26am 
If you have Steam installed to your C drive, the location of Star Ruler is most likely going to be C:\Program Files (x86)\Steam\steamapps\common files\star ruler

In that directory you should be able to find oalinst.exe and vcredist_x86.exe.
If the files do not exist, go to your library, right click on Star Ruler, go in to properties, click on the local files tab and choose the "Verify Integrity of Game Cache" option.

The files should be included as part of the download of the title; the files being absent should trigger an automatic update for Steam to grab the files it needs. If you've told Steam to not automatically update Star Ruler that could also be a potential cause.

If Steam won't grab the necessary files when told to find them and the files don't exist on your machine then I would urge you to contact Steam support.

-----------------------------------------------

Reminder: When installing anything that messes with drivers and so forth from a trusted source always right click on the installer and choose to run it in Administrator Mode. Otherwise there's no guarantee that the installer will be able to access the directories that it needs to in order to actually install. Since Program Files(x86) and Program Files both are under UAC, modifications to those directories can sometimes be blocked by UAC getting a little overzealous; this could theoretically prevent OpenAL or the VC Redistributable from installing anything to your Steam directory.

All of that is entirely contextual to how you've set up your Program Files(x86) or Program Files directory, whether you're running above Vista, your OS settings, and the permissions given to the user account that you're currently signed in to when you try to install OpenAL/VCRedist. As such, that advice may not be relevant to everyone and if following the above doesn't work for you, then the next step is to contact Steam Support and open up a ticket.
Last edited by Firgof Umbra; Feb 18, 2013 @ 2:45pm
theolivegarden Sep 19, 2012 @ 7:49pm 
I tried everything in this thread and I'm getting an error saying "MSVCP100.dll" is missing from my computer.
Thy Reaper  [developer] Sep 19, 2012 @ 8:01pm 
You'll need to run vcredit_x86.exe, or find Visual Studio 2010 Runtime direct from Microsoft.
drydenjake Oct 5, 2012 @ 10:24pm 
when i hitm play game it sayd preparing to launch game and then it goes away and nothing comes up ? any sugjestions
Thy Reaper  [developer] Oct 5, 2012 @ 10:46pm 
Originally posted by drydenjake:
when i hitm play game it sayd preparing to launch game and then it goes away and nothing comes up ? any sugjestions

You'll need to follow the instructions in this thread.
drydenjake Oct 7, 2012 @ 8:57am 
idk how to do any of these things you all are talking about or even what they are ??
Thy Reaper  [developer] Oct 7, 2012 @ 7:32pm 
Originally posted by drydenjake:
idk how to do any of these things you all are talking about or even what they are ??

You need to navigate to a folder and run an exe. The folder and exe are explained in this thread.
Biscuits Akimbo Nov 15, 2012 @ 9:20pm 
Let me just start by saying how dissapointed I am by this game. It looks great, and right up my alley, but I bought it during the summer sale and still haven't got to playing because it just is too difficult for me to get running. You said in another thread that it's a problem with the Open Al, or something along those lines. This is what annoys me most: I own nearly 200 games though steam, and never have they been ridiculously difficult for me to actually play. Please, don't make excuses for what are clearly your own failures.

Now, this is what I've done thus far:
1. I've tried running "oalinst"
2. I've copied OpenAL32.dll into the Star Ruler folder
3. I've tried running vcredist_x86, it says " A newer version of Microsoft Visual C++ 2010 Redistributable has been detected on the machine."

What could I do beside these three steps? I've checked on other threads and this seems to have fixed it for most people.


Thy Reaper  [developer] Nov 16, 2012 @ 3:29pm 
It isn't our fault, because it is related to some specific circumstance of multiple installs of OpenAL performed in an incorrect way. Steam's install steps runs the install of OpenAL, and has been outside of our control until very recently, and even then the fault may be some other game's install script.

Please email me at admin@blind-mind.com, or use our forums for a faster response. We need to know the symptoms of your launch issue. If it fails to launch at all, and provides no message because of Steam's wrapper, then it should be fixed by your listed steps. Any other set of symptoms is not caused by OpenAL.
Last edited by Thy Reaper; Nov 16, 2012 @ 3:32pm
Lord_Of_Sabers Nov 21, 2012 @ 1:48pm 
i'm haveing the same problem i've reinstalled 2 times valadated at least 10 times and did all the recomendations on this page but nothing worked when i use steam it just doesent open when i use the launcher i get the same error as umbral reaver does anyone have any other sugestions? (note i installed the demo to and that runs just fine)
Showing 1-15 of 80 comments
< >
Per page: 15 30 50