Ataliano Jul 13, 2013 @ 4:49am
Unable to play Commandos 3 under 7-64 bits fixs applied
I bought the pack yesterday thinking it would work on my system (cause usually even they're old games they're at least ported to the last OS to be able to work, as far I've seen in other games such as Sim City 4).

First of all it doesn't start at all, just blackscreen and crash to desktop. Then, putting the .exe in admin mode, it gives the "Failed to find Steam" error, which should be able to fix by adding environemtal settings path for Steam in 64 bits mode (Program files (x86)) but it doesn't work for me neither. Now it shows a message saying "Failed checking Steam system" or something like that.

So, I'm sick of trying manual patches for giving this a try... I saw latter that in game page it says Xp but not Vista or 7, but men, that should be more visible advice taking care that most steam users uses Vista or 7 even 8 porbably... bad move.

Any suggestion?
Showing 1-15 of 28 comments
< >
Kuiper Jul 13, 2013 @ 8:41am 
Windows8 here, the game starts but is glitchly and unplayable!
Last edited by Kuiper; Jul 13, 2013 @ 8:59am
[L3]puppet610 Jul 15, 2013 @ 12:10am 
im having an issue where it is just a tab on my screen and cant even load anything it is annoying as hell and im ♥♥♥♥ED as well and steam has yet to respond to me
Ataliano Jul 15, 2013 @ 6:39am 
Same here, it's true that in specs it says up to W2000 I think, but they should put a bigger advice for those kind of games as other old games are getting patched for working in 7 and on... I just bought it thinking it would have the patch and read latter the problems it got :(

Anyway, a weird thing is that Commandos 1, expansion and 2 works, really crappy (can't change screen resolution and in 2 all goes like turbo (twice the normal speed), but at least they open). I though the newer one would be the best in new OS, but seems that nope :S

I opened a ticket on Saturday and no answer by the way. Let's see if steam says something cause also, the support link for the game goes to a bad URL (square enix...) and obviously they don't give support for Commandos (it doesn't even appears, as it's a Spanish standalone game which if I'm not wrong another company bought, but I think it wasn't square enix but ubisoft or similar).

The crappy thing is that I oppened a ticket cause I got problems to buy it at the beggining and this was solved in minutes, but now I've spent my money and got problems again nobody answers... but let's be nice and think it's cause summer sale saturation... I hope.
Last edited by Ataliano; Jul 15, 2013 @ 6:42am
LeoLaxes Jul 15, 2013 @ 12:06pm 
Hello, I'm on a win 7 x64 system, playing this game without problems. Some time ago, I was having problems with another game, I found (cant remember where) that some games have issues with the /Program Files (x86)/ path. So I moved my steamapps folder to my D: drive, right on the root of the drive. I think if you move the steamapps folder to another folder with a simpler path, like C:/mygames or D:/ could help you. It's worth the try, and the instructions to do it are on the Steam support page.
Bürdo Jul 16, 2013 @ 1:40pm 
I bought the pack also, I have a windows 8. The game installs properly but once you are in-game, the graphics are all glitched up its impossible to play. I contacted steam cuze I wanted a refund on a game that does not work for windows 7/8, ( most gamers use windows 7/8 nowadays ), on the steam store game page It does not tell you any compatibility info, I told the support team that but no they find excuses to not refund you, although its a legitimate reason.

I'm surprised this is still on the steam summer sale list, hope no other gamers fall victim to this game.
Last edited by Bürdo; Jul 16, 2013 @ 1:41pm
Ataliano Jul 17, 2013 @ 11:41am 
LeoLaxes, tried both and I'm still not able to make it run, or "Failed to find steam" or "Failed checking steam files" (or similar), but never achieved to play the game.

Still without answer from steam... I wish they can at least refund the credits into my steam wallet so I can buy something playable... :(
pyrilin Jul 17, 2013 @ 1:42pm 
same problem here =(
krashd Jul 18, 2013 @ 11:10am 
Ataliano, don't make ♥♥♥♥ up. SimCity 4 has not been ported.
Ataliano Jul 18, 2013 @ 12:04pm 
krashd, calm down. It may haven't been ported but anyway it works perfectly with windows 7 64 bits (I've got it and I was playing it until the new one came out, buyed it on lastest sales).

The matter here is that commandos doesn't even launch. I've tried all solutions provided and the only thing I've got are different errors shown but no way to enter the game. Both games are from 2013, the difference is that commandos doesn't have such a large community and there isn't any message saying "This game is not supported under windows 7 64" for example at the shop, just the requirements... and a game which is that old is suposed to work perfectly under new hardware setups, and you might not advice about the OS...

Also, I opened a ticket on Steam Support just asking if there's any way to get the game running but no answer gave since 5 days ago... I doesn't think that's a nice support service...

That's why I'm yelling, and as you can see, I'm not the only one, and there's no answer by steam overall saying something...
LeoLaxes Jul 18, 2013 @ 12:21pm 
Hey Ataliano, Im sorry the path fix didn't work. Right now I can't think of any other solution to it. I hope Steam refunds you and everyone who can't play the game.

I don't know if the OS is the culprit to the problem, I can play with a Win 7 x64 system (i7, GT540M, 8GB Ram), and you'r right its an old game that its supposed to work on new hardware setups. The only game I havent been able to play correctly is Magicka :(

Maybe you can trace the game process from launch to failure, using process monitor from Microsoft Sysinternals, if you'r up to it I could trace mine and compare both so we can pinpoint where and how it crashes.

Antasena Jul 21, 2013 @ 2:51am 
Guys,

I'm running windows 7 too but in 32 bit. Can't play it because windows said "commandos3.exe stop working" and thats it. No solution. Anyone can help?
virtuask2 Jul 27, 2013 @ 1:05am 
Same problems here (windows 8), rendering failures sniper scope glitches and menu is messed up.
Ataliano Jul 27, 2013 @ 4:51am 
They answered me responding that we should fix up steam directory:

- Open MS-DOS (Start -> search -> CMD and open it as administrator)
- Write this: "C:\Program Files (x86)\Steam\bin\SteamService.exe"/repair (quotation marks included)
- It should do a quick fix over Steam Service
- Close, restart, and try

For me hasn't worked, and I'm lack of asking and getting more and more troubles. Also they've told me that there's no way to get refund or change the game for another one with same value or higher...

Next time I buy I would think it twice before clicking "buy" in Steam... very annoyed.
Xerius Jul 29, 2013 @ 10:02pm 
What worked for me is that the commando's folder was set to read-only - uncheck it. bam worked.
Xerius Jul 29, 2013 @ 11:26pm 
I also forgot 2 steps i took before i did that - right click commandos3.exe and run in compatability for windows XP Service Pack 2 and also put the steam.dll in the commandos folder. hope this helps.
Showing 1-15 of 28 comments
< >
Per page: 15 30 50