The Polynomial > 一般討論 > 主題細節
Error 2013 年 01 月 24 日 @ 下午 12 時 59 分
Linux version - game freezes after enemy killed
After killing an enemy (not the first one, about 10th or more) game freezes, freezing whole gnome, CPU of steam's MainThrd process rises to 99% and I have to kill the process. Maybe it's the issue of adding achievements, they're showed in console but don't add to steam. Console output before terminating the process:

(754:Update) Target lost
(304:SetAchievement) killed_1_enemy
(1051:OnDeath) kaboom
Terminated

Is there any standalone client that doesn't require steam to check if it's steam's issue?
顯示 1-10,共 10 則回應
< >
dmytryl  [開發人員] 2013 年 01 月 24 日 @ 下午 2 時 05 分 
Just run it directly (navigate to your steam folder), without the Steam running. I'll try to fix the hang - i don't sure it happens to anyone else though.
最後修改者:dmytryl; 2013 年 01 月 24 日 @ 下午 3 時 28 分
Error 2013 年 01 月 24 日 @ 下午 3 時 00 分 
So I couldn't run it without steam running, segfault on loading steam libraries, but I could run it with steam running directly from steam folder without steam seeing this. It fixed the freeze thing so it's probably the achievement thing. It'd be nice to see a fix to that soon, it's always nice to have steam chat in game ;] Thx anyway!

@Edit
Hmmm I played for some time and it froze on enemy kill again ;/
最後修改者:Error; 2013 年 01 月 24 日 @ 下午 3 時 30 分
Error 2013 年 01 月 24 日 @ 下午 3 時 38 分 
./Polynomial32: line 2: 13487 Segmentation fault (core dumped) LD_LIBRARY_PATH="./bin/lib32:$LD_LIBRARY_PATH" ./bin/Polynomial32
That's what I get while trying to run it without steam running
Bapho - back in t. this weekend 2013 年 01 月 25 日 @ 下午 11 時 44 分 
disable compiz. use classic gnome , compiz causes lots of issues lol.
Error 2013 年 01 月 26 日 @ 上午 3 時 10 分 
It's not a gnome/compiz issue, same thing happens on kde. I'd like to try it without steam running, but steam libraries yell for it.
最後修改者:Error; 2013 年 01 月 26 日 @ 上午 3 時 10 分
dmytryl  [開發人員] 2013 年 01 月 26 日 @ 上午 6 時 37 分 
Does it happen to anyone else? I can't reproduce it. I need to somehow narrow down this issue...
最後修改者:dmytryl; 2013 年 01 月 26 日 @ 上午 6 時 38 分
Error 2013 年 01 月 29 日 @ 上午 5 時 15 分 
Gawd damn it, I wanna shoot some enemies without killing the process every 10 minutes :[!
Error 2013 年 02 月 2 日 @ 下午 2 時 35 分 
Hmm, after latest update of steam it no longer freezes, played for 30 min, killed about 50 ememies and it didn't freeze. I hope that was steam's issue and it will work from now on, yey :D!
intelfx 2013 年 03 月 17 日 @ 上午 3 時 28 分 
dmytryl 發表:
Does it happen to anyone else? I can't reproduce it. I need to somehow narrow down this issue...

For me, it happens each 10 minutes. Actually, the steam's version was 1) linked to old versions of OpenEXR/ILM libraries (*.so.6) and 2) showing pretty bad performance, so I've re-purchased it from official site. So, rev135 build has normal performance but still linked to these old libraries -and it crashes (to launch Polynomial, I just symlinked *.so.6 to *.so.7).

Dmytry, could you please relink against newer OpenEXR (*.so.7)? Maybe this is the problem
intelfx 2013 年 03 月 17 日 @ 上午 3 時 32 分 
(actually, the so-version has been bumped in openexr 1.7.1)
顯示 1-10,共 10 則回應
< >
每頁: 15 30 50