Loliver 24 jan 2013 à 12h59
Linux version - game freezes after enemy killed
After killing an enemy (not the first one, about 10th or more) game freezes, freezing whole gnome, CPU of steam's MainThrd process rises to 99% and I have to kill the process. Maybe it's the issue of adding achievements, they're showed in console but don't add to steam. Console output before terminating the process:

(754:Update) Target lost
(304:SetAchievement) killed_1_enemy
(1051:OnDeath) kaboom
Terminated

Is there any standalone client that doesn't require steam to check if it's steam's issue?
Affichage des commentaires 1 à 10 sur 10
< >
dmytryl  [développeur] 24 jan 2013 à 14h05 
Just run it directly (navigate to your steam folder), without the Steam running. I'll try to fix the hang - i don't sure it happens to anyone else though.
Dernière modification de dmytryl; 24 jan 2013 à 15h28
Loliver 24 jan 2013 à 15h00 
So I couldn't run it without steam running, segfault on loading steam libraries, but I could run it with steam running directly from steam folder without steam seeing this. It fixed the freeze thing so it's probably the achievement thing. It'd be nice to see a fix to that soon, it's always nice to have steam chat in game ;] Thx anyway!

@Edit
Hmmm I played for some time and it froze on enemy kill again ;/
Dernière modification de Loliver; 24 jan 2013 à 15h30
Loliver 24 jan 2013 à 15h38 
./Polynomial32: line 2: 13487 Segmentation fault (core dumped) LD_LIBRARY_PATH="./bin/lib32:$LD_LIBRARY_PATH" ./bin/Polynomial32
That's what I get while trying to run it without steam running
Bapho - back in t. this weekend 25 jan 2013 à 23h44 
disable compiz. use classic gnome , compiz causes lots of issues lol.
Loliver 26 jan 2013 à 3h10 
It's not a gnome/compiz issue, same thing happens on kde. I'd like to try it without steam running, but steam libraries yell for it.
Dernière modification de Loliver; 26 jan 2013 à 3h10
dmytryl  [développeur] 26 jan 2013 à 6h37 
Does it happen to anyone else? I can't reproduce it. I need to somehow narrow down this issue...
Dernière modification de dmytryl; 26 jan 2013 à 6h38
Loliver 29 jan 2013 à 5h15 
Gawd damn it, I wanna shoot some enemies without killing the process every 10 minutes :[!
Loliver 2 fév 2013 à 14h35 
Hmm, after latest update of steam it no longer freezes, played for 30 min, killed about 50 ememies and it didn't freeze. I hope that was steam's issue and it will work from now on, yey :D!
intelfx 17 mar 2013 à 3h28 
dmytryl a écrit :
Does it happen to anyone else? I can't reproduce it. I need to somehow narrow down this issue...

For me, it happens each 10 minutes. Actually, the steam's version was 1) linked to old versions of OpenEXR/ILM libraries (*.so.6) and 2) showing pretty bad performance, so I've re-purchased it from official site. So, rev135 build has normal performance but still linked to these old libraries -and it crashes (to launch Polynomial, I just symlinked *.so.6 to *.so.7).

Dmytry, could you please relink against newer OpenEXR (*.so.7)? Maybe this is the problem
intelfx 17 mar 2013 à 3h32 
(actually, the so-version has been bumped in openexr 1.7.1)
Affichage des commentaires 1 à 10 sur 10
< >
Par page : 15 30 50