redxson Aug 26, 2013 @ 7:54pm
HELP!!!! FPS drop problem
Hi there, i have a FPS problem in the game.

My computer config is
CPU: i7-2600
Graphic Card: GeForce GTX 650Ti Boost
Hard disk: Intel 520 160GB SSD
Ram: 12GB Ram
Game graphic setting : medium to high (i ve try this two options but same problem)

When i m playing some maps with huge amount of monsters, the FPS will drop to lower than 13 FPS (i have checked the PC temperature is only about 60C) , but my friend's PC config lower than me have not this problem (such as geforce 740M even intel graphic 4600), I dont know what happen, does any setting can help to improve this problem? Thank you so much for your attention.
Showing 1-9 of 9 comments
< >
Flaktok Aug 26, 2013 @ 11:51pm 
Before you launch the game press, Configure > GFX/SOUND > Disable Vsync and tick "don't use multi-threaded renderer"

Is your drivers up-to-date?
Road Aug 27, 2013 @ 2:10am 
also in game you can turn off damage numbers this gives me some trouble when you got massive numbers flooding the screen from auras and turrets and traps just hit escape options and it should be right there just uncheck damage numbers.
Flaktok Aug 27, 2013 @ 4:04am 
Also postprossecing(not sure that is writen right)
redxson Aug 27, 2013 @ 9:56am 
thank you so much, Ispind and Road, the DPS is now ok !! thank you!!
Zeroko0 Aug 31, 2013 @ 1:06am 
Originally posted by Ispind:
Also postprossecing(not sure that is writen right)

leave the postprocessing check or uncheck it?
Flaktok Aug 31, 2013 @ 2:13am 
uncheck it
[Risk] Galiant Sep 1, 2013 @ 1:49am 
Is it supposed to make the game look a bit darker and washed out when you turn postprocessing off?
Flaktok Sep 1, 2013 @ 3:25am 
Yes, it should increase the FPS
Chris leo III Oct 26, 2013 @ 5:32pm 
Nvidia Ver 331 have bug lag 20 fps use 30% of gpu
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Aug 26, 2013 @ 7:54pm
Posts: 9