Heavens Inc. Mar 6, 2013 @ 2:05am
[Linux|HumbleBundle] Does not install anything
Hi
I got dungeon defenders in the Huble Bundle, but when i try to install it, it does not download anything (Humble-Bundle says it should be 5 GB) and i can't launch it because there is no executable
Is that a common bug, or only related to me?
Kattalunikes
Showing 1-15 of 27 comments
< >
Piesko Mar 6, 2013 @ 2:30am 
It happens to me too.
damn_pastor Mar 6, 2013 @ 2:30am 
Already known issue. This game was in an earlier bundle too and is still noch available...
Ghost99 Mar 6, 2013 @ 4:12am 
Same thing. Some other steam linux games had similar problem.
Areso Mar 6, 2013 @ 7:23am 
Interesting in it, 'cause it was a most-interesting game in bundle as for me.
There are SteamPlay, but no Linux In description on Steam game page.
Second, I tried it from client - there are Dungeon Defenders in Linux games hub, but within installation it only creates shortcut.
Double-click on shortcut "Failed to start game (missing exec)."
May be it can be installed via Mojo Setup, but it looks hard to me (I don't even know how-to install Mojo Setup... there are no deb on theirs page, only source code).

Awaiting for updating, which allows correctly installation under Linux.
Last edited by Areso; Mar 6, 2013 @ 7:24am
WhiteBlack-Vulcan734 Mar 6, 2013 @ 9:27am 
guys the problem is probably realated to your computer because i also bought the humble bundle and i can use the game. Try to delete your steam files. It worked for me one time when i couldnt open a game that before i could and doing that worked. (delete all steam files)
Altavatar Mar 6, 2013 @ 9:45am 
I'm experiencing the same issue. I've tried deleting local data, and making sure that the DD dir in ~/.local/share/Steam/SteamApps/common is deleted, then reinstalling - doesn't help.

Anyone have any other ideas?

Edit.
I tried "verifying" the install, which passes, but the ~/.local/share/Steam/SteamApps/common/Dungeon Defenders/ directory is empty.
Last edited by Altavatar; Mar 6, 2013 @ 9:52am
dr7 Mar 6, 2013 @ 11:08am 
This is common with Linux Steam, games that are newly released or under development with Steam integration will show up in your list but have nothing to download. On the Beta tab of these including this game are often Linux closed betas (available with a password only known to some).

It's happened before with several games and sadly will probably continue to happen -- I really wish they would just leave it off until it's publically available because it is confusing.
Garog Mar 6, 2013 @ 11:20am 
Happens to mee too, what download regions do u use ? and is it working or not for u ;) ?
lae Mar 6, 2013 @ 2:00pm 
As for the time being, you can just download the .mojo.run file and extract it (it's a bzip2-compressed tar archive) to someplace like /opt/DungeonDefenders, and then symlink the binary:

ln -s /opt/DungeonDefenders/DungeonDefenders /usr/bin/dungeon-defender

In case it doesn't run, check to see if libstdc++5 is installed (it might be named differently in your distro's package manager).

Hopefully it'll be available via Steam soon.
Softspokenman Mar 6, 2013 @ 11:00pm 
you can play dd with out steam you just can't play on ranked
AIPHEE Mar 7, 2013 @ 1:02am 
You cant play online in Linux yet, but the fact that game appered in list shows that it ll probably come to Linux Steam.
Timberwind Mar 7, 2013 @ 3:09am 
Someone posted here a link, where you could see this game is already in a beta stage for steam linux. :) I don't remember where exactly right now. In a few weeks it will be online for sure.
sx Mar 7, 2013 @ 5:17am 
Originally posted by AIPHEE:
You cant play online in Linux yet, but the fact that game appered in list shows that it ll probably come to Linux Steam.

If it's in the list it will be released for sure.
[ARCH LINUX] cRaZy-bisCuiT Mar 7, 2013 @ 5:39am 
Originally posted by AIPHEE:
You cant play online in Linux yet, but the fact that game appered in list shows that it ll probably come to Linux Steam.

That's not true! If you own the Humble Bundle you can use that version to play under Linux quite well. But the Linux version is coming up. How to fix the HiB version to run under Linux and how to fix it I quote a post of the developer from Bugzilla:

Ryan C. Gordon 2013-03-06 18:29:08 EST

Ok, so this is really embarrassing.

The game went out with an accidental last-minute change in an .ini file.

In the directory where you installed the game, edit the file:

UDKGame/Config/DefaultDunDef.ini

Right near the top are two lines like this:

DefaultGameplayLevel=LobbyLevel_Valentines2013.udk
DefaultGameplayLevelRanked=LobbyLevel_Valentines2013.udk

Change them both to be LobbyLevel.udk ... then it will work.

I'm really sorry about that, we were working on the Steam version at the same time, and it still had the Valentine's Day customizations in it, which were taken out for the Humble Bundle. That simple edit will get you going, so no need to redownload something, but I'll also update the Humble Bundle build.

--ryan.

Source: https://bugzilla.icculus.org/show_bug.cgi?id=5894#c2
07.03.2013
(dd.mm.yyyy)

Int the very end you can see he is working on it. But usually he takes his time. ;)
Last edited by [ARCH LINUX] cRaZy-bisCuiT; Mar 7, 2013 @ 5:40am
sx Mar 7, 2013 @ 6:39am 
Well, I really like that there exists that way of communicating with the developers, this makes life so much easier. When you look at the big game publishers, which one would offer such kind of support? :)
Showing 1-15 of 27 comments
< >
Per page: 15 30 50
Date Posted: Mar 6, 2013 @ 2:05am
Posts: 27