Steels12 Jan 7, 2013 @ 1:19pm
Dungeon Defenders won't launch?
Hello all, I know this seems to be a common problem among the Dungeon Defenders communtiy but I can't find an answer to my specific problem.

First and foremost, YES I have tried varifying my integrity but no, it unfortunately doesn't work. The only other thing I've heard is to rename DungeonDefenders.exe to something useful, and then rename DunDefGame.exe to DungeonDefenders.exe, this unfortunately doesn't work either.

I'd appreciate any help you can provide as I bought this game in the Humble Bundle and am eager to try and hopefully join your community.


Thank you once again,
Steels12
Showing 1-5 of 5 comments
< >
Steels12 Jan 7, 2013 @ 1:24pm 
just in case this helps, here is exactly what happens when I launch the game:

I press the Play button.
The "launching Dungeon Defenders" prompt pops up
The prompt dissapears and my mouse begins bugging out, switching between a normal mouse and one with a spinning loading ball (which is quite annoying and can't be removed unless I log off)
Capt.Fantastic Jan 7, 2013 @ 2:03pm 
I'm sorry I can't be much help to you, as I've never had this problem.

The first and simplest thing you could try is to launch steam as an administrator.

If that doesn't work, try re-installing XNA (http://www.microsoft.com/en-us/download/details.aspx?id=15163). I had a problem somewhat similar to yours, just that it was with Magicka. Re-installing XNA solved that problem, so it might solve yours.

Good luck.
Steels12 Jan 7, 2013 @ 2:32pm 
ah, I fixed the issue. It seems that although permissions in general weren't an issue, but specific issues in my steam folder were causing an error in the game.

Thanks Capt.Fantastic
War Jan 10, 2013 @ 8:06am 
Hey, I have exactly the same problem, so it would help me a lot if you could specify what exactly did you do to solve it :) Thanks!
Steels12 Jan 10, 2013 @ 12:31pm 
aw man, should have asked a few days ago. From what I remember it had to do with permissions (first and foremost, try running it on the administrator user just incase you're not). Aside from that I think that I went and added Dungeon Defenders into my "firewall safe" list and ensured that my antivirus software wasn't conflicting (I run avast incase you do as well).

That's about the gist of what I remember, I never had a moment where I knew if it would fix it or not, I tweaked some stuff but I'm almost certain the issue was with permissions.

Hope that helps
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Jan 7, 2013 @ 1:19pm
Posts: 5