The Corewillem Monk -Monks- Mar 29, 2013 @ 12:06pm
Cant change controls in linux
I have a problem i don't get the screen to change the settings when i start the game it starts the game automaticly.How can i change the keybinds in linux?
Showing 1-9 of 9 comments
< >
Dlife01 Mar 29, 2013 @ 12:33pm 
I couldn't either. so af was looking in the game installation folder of dungeon defenders and was able to configure the controls in the Config folder. There's a file called *Input.ini.

There you can change the controls, but make sure the keys aren't duplicated in the ini file. Had to solve with the E and F key.
Last edited by Dlife01; Mar 29, 2013 @ 12:34pm
The Corewillem Monk -Monks- Mar 29, 2013 @ 2:02pm 
Thanks i will try that :)
Sum Wun Mar 29, 2013 @ 3:22pm 
I had the same problem. So i just gave up and plugged a USB Xbox 360 controller in my computer. Works pretty well. Will have to try the suggestion above.
LinuxGamer Mar 29, 2013 @ 11:29pm 
I have the same issue, and just assumed that key bindings weren't configurable. Thanks for the info.
The Corewillem Monk -Monks- Mar 30, 2013 @ 2:21am 
Doesn't work for me :(
linux.devnull Jul 24, 2013 @ 3:58am 
The file to edit is located in directory $HOME/.local/share/DungeonDefenders/UDKGame/Config and is named (in my case) MAC-UDKInput.ini
Crono Dec 27, 2013 @ 1:20pm 
Originally posted by linux.devnull:
The file to edit is located in directory $HOME/.local/share/DungeonDefenders/UDKGame/Config and is named (in my case) MAC-UDKInput.ini
It worked for me.
Tyvm!
(From Kubuntu 13.10. Just in case)
Last edited by Crono; Dec 27, 2013 @ 1:21pm
Disappearing Bears May 26 @ 1:47pm 
Originally posted by linux.devnull:
The file to edit is located in directory $HOME/.local/share/DungeonDefenders/UDKGame/Config and is named (in my case) MAC-UDKInput.ini

I found the folder with the .ini files, but I don't have MAC-UDKInput.ini. None of the other .ini files have sensitivity settings or bindings. Every .ini file I've found for this game either doesn't change anything, or doesn't have sensitivity settings.

EDIT: The input config file is definitely missing and not installing, but I just manually replaced it with the default ini config file and I can change my sensitivity now.

1. Navigate to .steam/steam/SteamApps/common/Dungeon Defenders/UDKGame/Config
2. Copy DefaultInput.ini to the .local/share/DungeonDefenders/UDKGame/Config folder.
3. Re-name the new DefaultInput.ini file to Mac-UDKInput.ini
4. Edit the Mac-UDKInput.ini file and remove the following lines:
[Configuration]
BasedOn=..\Engine\Config\BaseUI.ini

Now you can use the new Mac-UDKInput.ini to modify key bindings and change mouse sensitivity.
Last edited by Disappearing Bears; May 26 @ 3:08pm
Hazaiki May 27 @ 2:57pm 
Originally posted by The Corewillem Monk -Monks-:
I have a problem i don't get the screen to change the settings when i start the game it starts the game automaticly.How can i change the keybinds in linux?

Hey, you can only change the bindings for the skills and defense keys.
All you have to do is hit T and that should bring up a menu with a few icons.
To change your skill and defense bindings, just click either "Hero" or "Summon Defenses" icons, after that hover with your mouse over the skill/defense you want to change and simply hold the number(1-0) that you want it to be binded to. :) had this problem too
I just didnt mind the bindings and went for this approach ^

Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Mar 29, 2013 @ 12:06pm
Posts: 9