Katak Jan 20 @ 10:04am
Too much performance possible?
Hey there,

First of all, my system:

i5-3550 (@3.3 Ghz, 3.7 Ghz boost)
R9 280x (Gigabyte OC Rev. 2) - Catalyst 13.12 whql
8 Gb Ram 1333 mhz

I'm having a strange problem with Dungeon Defenders. I freshly installed my new R9 280x and wanted to play Dungeon Defenders. Everything worked fine until I noticed some framrate drops when I looked to special places (eg. standing in front of the fire in the tavern and looking at it). These drops are just for less than a second but are annoying, because they happen everytime I look at these special places (but dissapear after less than a second).
With my previous card, a Radeon HD 7770, everything worked fine.

Note: My 280x doesn't even bother to increase fan speed, seems like it handles this game in idle.

Now I want to ask you if there are any knows issues of this kind (didn't find anything with google or steam/trendynet forums), either with the gfx-card or the newest Catalyst version.
Showing 1-15 of 15 comments
< >
Bulldogs Jan 20 @ 1:33pm 
This game hardly uses any GFX ram or GPU time (my native res is 1920x1200), i would imagine those synch issues are to do with software - perhaps your drivers need to be re installed.

Did you do a complete re install of windows when adding your gfx card?

It is extreme i know but it some times can at least rule out previous registry or software entries that are conflicting with your new card even though theya re from the same company (AMD).

I read a while back that when a game (some not all) installs it writes your hardware rendering device id into a file (or uses another method similiar) and uses that infomration even when in your case you have upgraded to a new card, thus the game / software is relying on incorrect information and can cause issues i imagine.


My system is a core i5 2500K @ 4GHz, 16GB DDR @ 1600MHz, Nvidia 670 GTX and i ahvent experienced this issue you say, i have vsynch enabled though via the game, and any power saving features within windows or through drivers i have disabled.
Katak Jan 20 @ 11:00pm 
Yes, before installing the new card, I updated my BIOS (Gigabyte Z77-ds3h) to the newewst version and erased everything. Also got the newest drivers for my hardware from my manufacturers site.
Katak Jan 20 @ 11:23pm 
+ Win 7 Prof. x64
The only program running in background is Logitech Gaming Software, but I already used this program with the HD 7770.
Bulldogs Jan 20 @ 11:41pm 
I would run GPU-Z in the background to monitor the gfx cards clocks and / useage of the gfx card processor, if can be found here - http://www.techpowerup.com/downloads/2317/techpowerup-gpu-z-v0-7-5/

I would look for the Clock speed (when in game have GPU-Z running and make sure when monitoring you have "Continue refreshing tis screen while GPU-Z is in the background" enabled)and make sure that it isn't fluctuating (from low to high, 2d mode to 3 mode clocks or idle even) also check the useage and make sure it is not sitting on %0 useage when you were experienceing the issue you describe.

Also make sure you have installed DX 9.xx as it is a seperate APi to DX 10,11 and a lot of ppl assume because they have 10 and or 11 they have 9 aswell, the version of DX 9 which ships with windows is outdated and MS never release updates for it via windows update within the operating system.

You can grab it here http://www.microsoft.com/en-US/download/details.aspx?id=8109 just dl that, the easiest way to install it is to extract it with 7zip or Winrar into its own folder and run the DXSETUP.exe as admin.
Katak Jan 21 @ 2:17am 
Ok, updating DirectX 9 didn't help. Using GPU-Z, the GPU load drastically jumps up to 95% and the GPU memory clock drops from 1500 mhz to 150 mhz while looking at these places.
Tydo Jan 21 @ 4:24am 
thats horrible. 150MHz on the memory sounds like the culprit. Overly agressive clocking down done by the drivers.
Harder to say what the GPU usage spike is, but i guess it is related to clocking down as well, making the load appear high.

You might want to try RadeonPro instead of GPU-z and put the core frequency on its OSD overlay so you can verify that it clocks down the GPU as well.
It really sounds like a case of overly agressive downclocking on low load to save power.
Last edited by Tydo; Jan 21 @ 4:24am
Katak Jan 21 @ 4:56am 
Yep, I'm thinking the same that it's a problem with the newest Catalyst. Should have mentioned that I used Catalyst 13.9 and previous versions with the HD 7770, but never 13.12.
Bulldogs Jan 21 @ 3:24pm 
Try (if it is possible) using the previous drivers you said were fine on your HD 7770, if that isn't possible i would post a thread in the Rage3D sub forums with your findings, there are a few AMD staff / devs or such that frequent there: http://www.rage3d.com/board/forumdisplay.php?f=59

You could also try the AMD game forums http://forums.amd.com/game/categories.cfm?catid=440&entercat=y and post a thread of your own to see if other AMD R2xx series owners are having similiar clock issues with those drivers, If you can reproduce the issue i reccomend posting the findings here: http://www.amd.com/report as it is the official reporting method for repoducable bugs so the techs can work on fixing them..


And as Tydo mentioned perhaps to verify the downclock is indeed ahppening at that same spot and can be replicated, use RadeonPro (found here: http://www.radeonpro.info/) instead of GPU-z as it has an overlay (OSD - On screen display).

Just be mindful using radeon pro *might* void your warranty, perhaps Tydo can clarify this - i dont know for cetain, but since your using a new card i assume it is under warranty i wouldnt want you losing the warranty incase you need it.
Bulldogs Jan 21 @ 3:31pm 
Also did you try the same spot with V-synch enabled (and test to see if the same issue occurs or not with or without it enabled) within your Catalyst control centre or via the Dungeon Defenders launcher?

The reason i ask is i run the game with V-Synch enabled and on my Nvidia 670GTX i don't see the game using much GFX processing at all when in game, even during heavy scenes. I will post back with what useage i have at the tavern looking into the fire for example and in a heavy rendered scene, it is apples vs oranges comparison i know but it might atleast show that it isnt a game bug and instead a hardware or software (driver) related issue.

Update one: GPU load when looking into the fire about 25-30% my clock speed was GPU 914MHz and GFX Ram useage was 272MB, running at 1920x1200 60Hz with v-synch on
Last edited by Bulldogs; Jan 21 @ 3:47pm
Tydo Jan 22 @ 1:07am 
IIRC The warranty part is only if you overclock using RadeonPro's settings (instead of the CCC), since overclocking can potentially cause heat damage and overload some components (or just drastically lower their lifespan), depending on how severely you overclock and how rugged the parts are.

You get a similar warning in the CCC if you enable manually setting the clocks and fan frequency - really just a disclaimer to cover people doing stupid things like maxing the clocks and setting fan speed to minimum or even off, or even setting voltages to unsafe levels on the pro-overclocker-friendly boards.

There is also some generic a**covering because RadeonPro lets you access a few things that are hidden away by the default CCC, some of which can cause compability problems - specially since, at least in theory, AMD/ATI could change the drivers to be highly incompatible with RadeonPro, making it not work as intended.
Not that it would be wise, but, you know, a "just in case they do" disclaimer.

Some games also highly dislike it. An example i stumbled across firsthand: Tropico 4 wont run while RadeonPro is running, no matter the settings, im guessing it detects the API hooking and for some nefarious reason wont play.
But mostly it is a handy tool.
Katak Jan 22 @ 5:59am 
Ok, deactivating Vsync helped. Memory clock stays at 1500 mhz all the time, GPU load stays at about 25%. But I will stick to Vsync, because I am used to play every game with Vsync, don't like the tearing.

Nevertheless, thank you two for your qualified help :)
Katak Jan 22 @ 10:51am 
And I reported the problem to AMD.
SCE_Genesis985 Jan 22 @ 11:57am 
you could also check out MSI afterburner, its has features that are similar to radeonpro, but is a universal program for both NV and AMD cards, also MSI afterburner has a video recorder built into it.
Dr. Dro Jan 23 @ 5:15pm 
Welcome to the master race, my friend. You nailed your problem spot on. That is a design flaw on every new graphics card available atm from either AMD or NVIDIA due to the fact they're, simply put, far too powerful to run 98% of PC games ported from the massively outdated consoles (including the "next generation" ones).

There are only a few ways to fix this problem,

- always play with VSync off (provided you are not CPU bottlenecked)
- BIOS modification, disabling throttling and boost mechanisms
- software control (if available on the red team; my last AMD card was an HD 5970 almost 5 years ago),
- manually gimping (lowering your maximum clock speeds) your card to a point it's so low that this workload will actually push it, or running something intensive on the background.

The real issue is that the game literally tickles the GPU, and due to the new boost functionality both from AMD or NVIDIA attempting to manage power usage and prevent excess draw in order to remain silent and cool cause it to idle under light workloads which is a very, very bad idea rendering performance-wise even if it's not being actually utilized to its full potential. AMD won't do anything about it, nor will the green side, because fixing it essentially means removing boost and advanced power saving features.

I get this problem with lots and lots of games, and I can confirm it's 100% related to "boost" function. It's real, real bad on the GTX Titan, unless you flash a proper BIOS like the no-limit NVIDIA engineering sample (which I use) or svl7 no-boost BIOS.

It gets even worse when you overclock it and lock games to run at lower framerates like 60 fps, i run mine 1202MHz and recently managed to find my way through a memory OC instability hole and managed to score a 1913MHz on the mem :O The BIOS i'm currently using has the low power 3D clocks set to the otherwise stock 836MHz unless overclocked and/or with double precision units on, so games generally run properly even under that condition due to the sheer strength available, but the effect is clearly there.

The overclocking community dreads boost features precisely because no machine can ever beat an human operator at configuring a system.
Last edited by Dr. Dro; Jan 23 @ 5:20pm
Katak Jan 25 @ 1:46pm 
That's what I wanted to hear, thanks :)
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Jan 20 @ 10:04am
Posts: 15