Acacia22 Dec 1, 2012 @ 9:13pm
Access Violation even when installed outside of Program Files
I thought I would give this game one more go before forgetting that Spellforce and Nordic exists.

I reinstalled Steam outside of the Program Files folder and FiD still coughs up an access violation error.

I only have one Spellforce2 folder in 'My Documents' and it has never been associated with SP2 Vanilla since several formats ago.

If anyone is wondering what I am talking about do a search for 'Access Violation Faith in Destiny' it should bring up a bunch of arguments in Nordic's forums where the MODs are more less saying they have no control over Steam but their retail copy works just fine.
Last edited by Acacia22; Dec 1, 2012 @ 9:14pm
Showing 1-15 of 16 comments
< >
Acacia22 Dec 1, 2012 @ 9:26pm 
Also, I went to check firewall exceptions and there are four of them for FiD for some reason. Steam.exe is excepted as well.

I also went and dropped the process for Deamon Tools in the instance that FiD had a DRM type that disables the game upon recognition of DVD-Drive emulation software.
Last edited by Acacia22; Dec 1, 2012 @ 9:27pm
Acacia22 Dec 1, 2012 @ 9:27pm 
Also dropped processes for Anti-Virus and Punk Buster.
MegalomaniacNG  [developer] Dec 2, 2012 @ 2:28am 
When does this Access Violation come up? I myself have Steam installed under C:\Steam\
Acacia22 Dec 2, 2012 @ 2:47am 
It happens no matter which mode I select from the menu screen.
MegalomaniacNG  [developer] Dec 2, 2012 @ 6:45am 
Yeah, I would need to know what is the last button you click on in the game to see what algorithm could be the reason.
Are you running as admin?
Acacia22 Dec 2, 2012 @ 11:04am 
Single Player and then any of the buttons under that category. I hear a *Dong!* and have to drop the window to see the OS error window that says "Access Violation, application will now close" and then FiD shuts down.

I think my user account is admin (there's no specific admin account set up except for Safe Mode) although if I right click and select 'Run As' for some applications it gives option for the same user who is defaulted For example "Willma/Fred" is default user - if I opt to manually select a user there is an account titled "Fred" (which I assume is the same as "Willma/Fred" with Wilma being the PC's name).

If I do manually select "Fred" Windows expects a password for which I never created one.
Acacia22 Dec 2, 2012 @ 11:18am 
Running a 'net localgroup' check in DOS lists moi as admin.
MegalomaniacNG  [developer] Dec 13, 2012 @ 1:36am 
Honestly this is a very strange issue. I would suggest to verify Steam cache files but please send me also your My Docs\SpellForce2 folder and give details about the hardware.
Acacia22 Dec 13, 2012 @ 1:50am 
Hmm....that might be a little tough. Since the 3rd I've overhauled my PC. That Presario mother board and Atholon 2400+ chip are long gone.

To be honest, now that I can play games like SO: The Line, I haven't been too concerned with attempting to re-download and mess around with Faith In Destiny.
BoomerzDude Dec 18, 2012 @ 8:06am 
I am getting this same error I'm at the Elves area Msomething Greens.
I completely deleted Spell Force: Gold since I read the save files didn't play nice with one another. Although I hadn't booted that game up yet I had it installed.
I forget the name of the Quest but it is for Io. You come up to a tree and you get some options. (Don't wanna spoil it) Right after I resurrected my character and then my game crashed. I reloaded the game and cannot click "Continue Campaign" it gives me this same access error.
I know I am running directx11.
I tried verifying integrity of game cache via steam.
I made sure there is only one Spellforce2 file in my docs.
MegalomaniacNG  [developer] Dec 18, 2012 @ 9:20am 
Did you try loading your savegame manually in the campaign menu?
BoomerzDude Dec 18, 2012 @ 10:39am 
When I go to campaign it doesn't give me an option to load any saved games although it shows my character's name it doesn't show any saves off to the right which can be loaded and I have an options to continue campaign (Which just causes me to crash)
I can start a new game I didn't try saving it but that seems to load up fine
I can see all my saves in document>SpellForce2>Addon1
BoomerzDude Dec 18, 2012 @ 10:45am 
Make that Addon2*

Dunno if it would work but I tried moving the save file folder between Addon1, Addon2 and the work file I have within there and loading up the game and see if that makes any difference.
Michael B Dec 18, 2012 @ 12:37pm 
Since the patch I am also getting access violations whenever I try to load a savegame, by clicking continue or from the Campaign menu, which does list saves. I've tried to load multiple savegames. Is there a way to roll back the patch without redownloading the whole game?
Last edited by Michael B; Dec 18, 2012 @ 12:38pm
BoomerzDude Dec 18, 2012 @ 5:18pm 
I believe for me it was just my auto save that was corrupted. I reinstalled and then after putting the save files back in I tried removing JUST the auto save file and it is now working again perfectly.
Minus that I'm getting beaten like an unwanted orphan at the moment lol
Showing 1-15 of 16 comments
< >
Per page: 15 30 50