Problems launching game
Ive been trying to launch this game for the past day and a half and its not working. When I try to turn on the game it just says 'Preparing to Launch Spellforce 2 - Faith in Destiny' and then that screen disappears like its about to launch, and then comes back like half a second later. I tried running steam in admin mode and tried launching the exe file directly and as admin and still doesnt work.
Showing 1-2 of 2 comments
< >
TotalAbyss Apr 4 @ 9:33am 
Be glad you dont have 8 hours in the game and can no longer load your save game. Crashs right away with a acess violation error. Which no one seems to be adressing on the forums or has a work around for.
Mister Bubbles Apr 26 @ 9:26am 
Originally posted by TotalAbyss:
Be glad you dont have 8 hours in the game and can no longer load your save game. Crashs right away with a acess violation error. Which no one seems to be adressing on the forums or has a work around for.

Throughout the following install NO unnecessary or extraneous software/hardware
Ensure your machine meets required specifications
Remove any unnecessary hardware
Reformat HD
Reinstall OS
Restart Computer
Install Drivers for system cards, keyboard/mouse
Update OS
Restart Computer
Install Steam
Restart Computer
Install King Arthur
Restart Computer
Load King Arthur

If you have issues now, update GPU sound and network drivers

Restart Computer
Load King Arthur

If issues are present now, refer to support.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50