qu4ntumrush Aug 14, 2013 @ 9:33pm
crashes a lot
First it crashed during the second benchmark and in the campaign it crashd when the big bug smashes into the room at the beginning. What's the deal?
Showing 1-10 of 10 comments
< >
Avelyn Aug 24, 2013 @ 6:19am 
me too :(
♫TGC> The Games Collector Sep 21, 2013 @ 5:41pm 
Can't even get past the intro, damn thing just crashes.

Operating System: Windows 7 Ultimate 64-bit
MainBoard: Sabertooth 990FX
Processor: AMD FX(tm)-8150 Eight-Core Processor (8 CPUs), ~3.6GHz
Video Card name: ASUS HD7970 Series

Anything that could cause that constant crashing, and more importantly, any way to fix it?
Last edited by ♫TGC> The Games Collector; Sep 21, 2013 @ 5:42pm
TopperHarley Oct 11, 2013 @ 12:35pm 
Hey guys , I just fixed my game! seems that that there is a microsoft update that is already installed in windows 7 that causes crash. I ununstalled that update and now at DX10 on full, no crashes. it's on here somewhere , just google Lonely Planet pc crash and youll find it... good luck!
ExiaRS #wengerout Oct 16, 2013 @ 2:24pm 
Remove Update KB2670838. Unfortunately it doesn't work for me.
ÐaNgeRis Dec 29, 2013 @ 6:22am 
How do you find the update to uninstall it? There are literally hundreds of them and not in order?

(EDIT- never mind, I found it. I have it but it hasn't made me crash so far...)
Last edited by ÐaNgeRis; Dec 29, 2013 @ 6:25am
ÐaNgeRis Dec 29, 2013 @ 6:19pm 
Having had this problem with other games (not this one, so far) it sounds like a graphics card driver error. They almost always cause crashes on startup. Frustrating. Make a restore point on your PC, and then use STEAM to update the drivers. That fixed a few games for me. Hope that helps.

Also, you may have to lower some of the graphical settings. Don't worry, it still looks good.
Last edited by ÐaNgeRis; Dec 29, 2013 @ 6:20pm
Fama Jan 5, 2014 @ 2:05am 
try playing on dx9. worked for me
pifficoid Sep 12, 2014 @ 12:06am 
FOUND A FIX THAT WORKS
Copy d3dx10_33.dll from windows\system32 directory to game directory and it seems to fix the problem as the file in lost planet directory is incorrect size for x64 systems
MrDOO Sep 12, 2014 @ 5:20am 
yes dll fix works was freezin for me on 2nd bench too all good now 6950 2gb crossfire working nice too on old x38-dq6 with qx9650 ...nice 1
Mystic Monkey Sep 15, 2014 @ 4:32pm 
Thanks for the fix about the dll i just had this problem, capcom need to sort there ♥♥♥♥♥ out this just lazy.

(Edit - Game just crashed on first part were you jump through the floor.. this sucks)
Last edited by Mystic Monkey; Sep 15, 2014 @ 4:39pm
Showing 1-10 of 10 comments
< >
Per page: 15 30 50