Fenix Mar 22, 2013 @ 11:12pm
Win7-64bit Won't Start/Failed to Find Steam
Howdy. I bought this a while back and could never get it to run. Thought I'd give it another go. I've tried the various methods listed on the forums and around the web: changing the path to steam, adding xp compatibility, running as admin (both steam and the program). Nothing has worked so far, unfortunately.

Has anyone else experienced something similar and, if so, were you able to finally get the game up and running?
Showing 1-2 of 2 comments
< >
Biskwik Apr 3, 2013 @ 6:47pm 
Mines even stranger, I bought the game over a year ago. I've launched the campaign 4 or 5 times, over the course of the year without issue.. I only got to the point where you dock your ship at the start. Do to life, I had to shelf the game for a while as I didn't have the time to dig in to it.. The other day I went to start it and no go. Dx9 failure was the pop up.. uninstalled then reinstalled still same. Confused as to why it would work fine a few months back and now no go.. This is not the only steam game to do this to me in the last few months since all the new steam updates have come in.. WTF? Computer gaming use to be fun, now it seems to be more about figurinig out what tweak you have to do just to get anything to work >:(
My comp is an xps lap top i5 (2294 mhz with turbo boost tech to 3.2) graphics is nvidia 525m fully updated drivers, and ram is 6038 mb.. I play dragons age origins, mas effect 3, crysyis 2, and many other demanding games without issue.

Last edited by Biskwik; Apr 3, 2013 @ 6:56pm
Camambert surprise Apr 5, 2013 @ 6:22am 
i've had a few older games do what u described above Biskwik, This game on my last install of windows 7 64 bit worked perfectly no hitches or anything, it wwas even modded and worked just fine. I reisntalled a month back and several old gamers just down right refuse to go, This (nexus does it and so do 2 of the 3 legacy of kain titles, Tho with LOK its the oldest one that runs perfeclty and the newer ones that don't. lol) I'm a little irritated at this though because I reallyw ant to play it.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50