Silver Knight Feb 19, 2014 @ 3:32pm
I find it hard to destroy enemy ships
I don't realy know which weapons are good and what there range it because mostly the ship keeps turning and not shooting.
Showing 1-10 of 10 comments
< >
12_monkeys Feb 20, 2014 @ 3:46am 
if they have shields, use lasers.. the ship will approach within range and fire.
- Select a subsystem so it focuses on that and destoys it, i usually start with shields then engines then weapons.
- No shields, hit attack Hull and it will just pound the ship to dust...

I never worried about range on this game since the ship will move into range when you give it the attack order.
Silver Knight Feb 20, 2014 @ 5:00am 
I'm using something called shieldbubble or something it wil damage the shields alot then i got 1 laser and 2 gattling guns to damage hull but sometimes they just won't fire. en esc key doesn't work anymore after alt tabbing
12_monkeys Feb 20, 2014 @ 5:14am 
Hmmm... not experienced this before... Have you tried mnually targetting? If you go to the "hand symbol" (next to the "spanner" for repairs), select the weapon and then target the ship (from the list on the right of the screen) and see if that forces them to fire...
Mazryonh Feb 22, 2014 @ 4:22pm 
What kind of stance are your ships set to? This sounds more like a bug arising from the game interacting poorly with your hardware--ships normally defend themselves well in this game.
Silver Knight Feb 22, 2014 @ 6:47pm 
Hostile if i don't have to send my commando's and scanning is a problem to because sometime my shield won't lower so i have to do it manuely and for a while i did't knew how .
FAButzke Feb 27, 2014 @ 7:06pm 
I can confirm this behavior. Actually this is something that happened to me long before the Steam version. I left he computer running for 10 minutes and the enemy ship was still there, circling mine, both firing at each other. The enemy ship was hitting me but not enough to bring my shields down. My ship (Angelwing) sometimes fired sometimes didn't (3 lasers: 2 heavy 1 light). Most of the time the few shots that my ship fired did not hit the enemy ship and when they did, it took so long to fire another shot that the enemy just repaired the damaged subsystem. I bet I could leave the computer for years and that would still be happening upon my return.

I noticed the same behavior with allied ships. That first escort mission where all the transports are pulled out of subspace and you have a NPC ship "helping" you. Sometimes he fights, sometimes he doesn't. He just goes straight into the enemies and take a pounding before even firing a shot. (making the mission all that much harder).

I never figured what causes this but I finished the game nonetheless. Mostly by saving reloading until the game decided to "work" properly.
wadingwater Mar 15, 2014 @ 5:44pm 
after the escort mission i started using shield damaging bubble thing had 2 of them and 2 hull damaging guns and 1 laser using this tactics worked with me till the end depleting shield then destroying the hull. same with the other ships you get i used the same except for sparta i think its called which has the datascanner and avalanche which is a missile frigate/heavy arty :)

manually targetting works when ships are in range and in the correct firing arc.... however it depends on the type of weapon generator you have AND power generators on the ship as you need to increase the power to the weapons on the power control. example on mission of disabling the lost escort ship i had all lasers and the raptors couldnt get through my shields and i was disabling their 3 ships with my laser in different directions. hope this helped :D
Sybreed May 4, 2014 @ 3:17pm 
Originally posted by FAButzke:
I can confirm this behavior. Actually this is something that happened to me long before the Steam version. I left he computer running for 10 minutes and the enemy ship was still there, circling mine, both firing at each other. The enemy ship was hitting me but not enough to bring my shields down. My ship (Angelwing) sometimes fired sometimes didn't (3 lasers: 2 heavy 1 light). Most of the time the few shots that my ship fired did not hit the enemy ship and when they did, it took so long to fire another shot that the enemy just repaired the damaged subsystem. I bet I could leave the computer for years and that would still be happening upon my return.

I noticed the same behavior with allied ships. That first escort mission where all the transports are pulled out of subspace and you have a NPC ship "helping" you. Sometimes he fights, sometimes he doesn't. He just goes straight into the enemies and take a pounding before even firing a shot. (making the mission all that much harder).

I never figured what causes this but I finished the game nonetheless. Mostly by saving reloading until the game decided to "work" properly.
perhaps they were out of power to keep shooting?
Silver Knight May 4, 2014 @ 4:04pm 
Nope everything is full and some were running on 200% to test it i tryed 100% on all changed nothing.
retroquark May 13, 2014 @ 3:46am 
It's not like it's a toggle. But when ships have ECM turned on, they prioritize protecting exposed systems from the closest ships. You also turn the ship in the same way, even if it means breaking firing lines. So if you're going in close and want to destroy a specific sub-system, disable your ecm, or override with focused behavior. In the same way, if you cripple the ecm on the fast ships, they can't avoid the locks as easily.

You can also get something that allows your ship to turn more quickly, so your lasers can get into firing positions more easily. All the placement of weapons as well can be tricky because of this - having lasers collected around the bow will increase the potential to get one and a half of the two pairs to fire all the time, for example.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50