For_Zion Sep 8, 2012 @ 7:26pm
No video
The video doesn't work for this game. It runs fine until I get to a part that needs a video like the books. Anyone know how to fix this?
Showing 1-15 of 21 comments
< >
mousedogg15 Sep 9, 2012 @ 8:17pm 
I've been having issues to with this game. I can't even get this this thing to run on Windows Vista...got any tips?
Last edited by mousedogg15; Sep 9, 2012 @ 8:47pm
For_Zion Sep 9, 2012 @ 8:39pm 
i'm running it on windows 7, i would try running as administrator or running in combatibility mode.
mousedogg15 Sep 9, 2012 @ 9:59pm 
I figured out my issue. In order to Run MYST: Masterpiece Edition, you have to have to have an older version (6.5.2) of QuickTime on your machine. You can download from www.oldapps.com or do a google search. I also had to set Myst.exe compatibility to Windows XP SP 2. Hopefully this is helpful news to all.
artistcaleb Sep 24, 2012 @ 2:49am 
I'm running Vista pro 64bit, I made it work, here's how:
First go into your steam apps folder, right click on myst.exe and set the compatibility mode to win98 (that's what I chose). Try running the game.
If that doesn't work, uninstall quicktime and install 6.5.2, then make sure the compatinility mode is win'98 (or so), and it should work just fine. NOTE, restart when making these changes just to make sure.
Check out my 'artistcaleb' youtube channel if you get a chance! (if you search for my channel, I'm not the graffiti guy you might see, look for the gaming vids and that's me).
I hope it works for you!! - artistcaleb
Extropic Engine Oct 1, 2012 @ 8:21pm 
I get the same issue with video on Windows 8, but when I try and run it in compatibility mode, I get a message from Steam telling me to turn off compatibility mode, and then it refuses to run.
For_Zion Oct 2, 2012 @ 9:13am 
Originally posted by extropic_engine:
I get the same issue with video on Windows 8, but when I try and run it in compatibility mode, I get a message from Steam telling me to turn off compatibility mode, and then it refuses to run.

same. I can't run it in commpatibility mode or any game on steam. It would be easier to just have the stand alone game.
dinner puppy Nov 16, 2012 @ 10:02pm 
Anyone find a solution for Windows 8 yet?
dinner puppy Nov 17, 2012 @ 11:59am 
I have Windows 8. At first I had no videos, so I did "Troubleshoot for compatibility." It set it to Windows XP Service Pack 3. The videos can play now, but the game keeps freezing, where no controls will work and the audio keeps skipping on the same spot. It usually happens when using quicktime elements. For instance pushing buttons in the generator room on the main Island always crashes it. Tried installing Quicktime 6.5.2 but that didn't seem to help.
VeinHarvest Dec 8, 2012 @ 7:25pm 
I fixed the problem easily (WINDOWS 7) by simply right clicking the game in your library in steam and click properties > select local files tab and click browse to local files > navigate to the exe file right click select properties > click compatibility tab > select to play in Win XP SP 2. Loads up and plays in game videos like a charm. Hope this helps.
Onwardparasites Jul 12, 2013 @ 11:56pm 
I bought Myst today as part of the Summer Sale. And I was having the same problem. And I found that if you right click on properties, select "Local Files", then "Browse Local Files...", it will bring you to a folder that has all of the game files and whatnot in it, find the Myst application (the one that says Myst and has a book...), and then right click on it, then select properties. This should open up yet another window, and from there select the compatibility tab, click the checkmark for "Run this program in compatibility mode for:" and in the dropbox, select "Windows XP Service Pack 2". And even if you don't feel like running XP, Windows 98 should do the trick.

Funny thing is... This is the first time compatibility mode has ever worked for me, haha, I own a lot of older games, and compatibility mode has failed for all of them (Trespasser for example)... But hey, it works for Myst! I was honestly suprised!

Either way, this is a great and easy solution, and the videos will run just fine!

Enjoy your game,
Onward
=BiE=SalamiSlicer Aug 18, 2013 @ 10:09am 
I also have problems with Myst Masterpiece Edition that no video on Windows 8 will be played. Compatibility mode with XP and Win98 did not help. Any other suggestions?
.NightHawk | RvG» Aug 28, 2013 @ 3:10am 
ok here it goes if this helps than im happy now depending on most systems which run 7 or vista its all to do with the video catalyst driver ATI ( get rid of the beta and go stable version) i know usually beta means yay better but in ati's case it means uhoh nightmare. and for nvidia users most game clients even myst masterpeice edition require direct x 10 ot 11 to run smoothly or at all... so check your direct x version and vid card drivers first. if those are good thn its time to call the manufacturer.... thats as far as i can go cause i build custom rigs and im not to good with prebuilt store pc's. i can fix em but as far as software compatability that dell and so on end.
.NightHawk | RvG» Aug 28, 2013 @ 3:12am 
Oh and ps for the windows 8 user go back to vista or 7 because windows 8 is a tablet optimized window op system, so unless you have the asus e transformer or something similar it wont work how you want it to
paul_simpson30 Sep 20, 2013 @ 10:09am 
4. enter in the box C:\Program Files(86x)\Steam\SteamApps\common\Myst Masterpiece\Myst.exe and then select 'next'
5. choose 'troubleshoot program'
6. choose 'program worked in earlier versions of windows but won't install or run now' This isn't eaxctly the problem that I was having, but it is the correct choice, trust me. choose 'next'
7. choose 'windows xp service pack 3' choose 'next'
8. choose 'test the program' this will open the game, and should show the intro videos. I couldn't see these before as none of the videos would work. If you can see the intro videos then the problem is solved. if you're happy with the game close the game window and choose 'next'
9. choose 'yes, save these settings for this program'
10. If you get a message saying 'issues found incompatible program' then ignore this, choose 'close'. close the troubleshooting window too.

Game should work now. If it does then I am happy I could help, otherwise I am sorry I couldn't help you, and you have my best wishes for your quest to make myst work
Last edited by paul_simpson30; Sep 20, 2013 @ 10:10am
paul_simpson30 Sep 20, 2013 @ 10:14am 
For some reason my post was cut in half. Here's part 1

I downloaded Myst Masterpiece Edition from steam, and so the usual compatibility options weren't available. I am using windows 8, and used this method to get the game to work, videos and all.

1. Open the control panel and choose 'find and fix problems' from the 'system and security' section.
2. under 'programs' choose 'run programs made for previous versions of windows.
3. in the new window that opens, choose 'next. then choose 'not listed' from the list of programs. if you have installed the game from a disc then the program may be listed here, but as I downloaded from steam it isn't.
Showing 1-15 of 21 comments
< >
Per page: 15 30 50