Roland The Jabberwocky Jun 26, 2013 @ 12:48pm
Myst: Masterpiece Edition Wont Start At All
I bought this around Christmas on gift card, and just got around to trying it out. However when I try and launch it, nothing happens whatsoever! No error messages or anything, I checked the task manager and all that happens is that it just stops running. Please help! I also have tried uninstalling and re-downloading, I run windows 7.
Showing 1-7 of 7 comments
< >
Neph Aug 1, 2013 @ 8:46pm 
Not sure if you have found a solution to this yet, but I hope I can help.

Try running it in compatibility mode. Go into your documents and find the game. I think the pathway is: [whatever drive you have it on] -> Program Files [It might be Program Files (x86)] - Steam -> steamapps -> common -> Myst. That could be entirely wrong depending on where you installed it to, but basically you have to find the Myst folder. Within that folder, find the application. It should end in .exe. Right-click it and tell it to troubleshoot compatibility. If you can set it manually, try setting it to Win 98 or earlier.

I know it sounds like a bit of a pain, but it's worth it! Hopefully that will help it start up. If not, I'm not sure how to fix it. However, this is a pretty old game, so most computers nowadays need help to know how to even open it, let alone run it.

Hope this helps! Happy travels through Myst!
Roland The Jabberwocky Aug 2, 2013 @ 4:46am 
Thanks! Ill try this right away!
Noitalever Feb 19, 2014 @ 12:48pm 
Try contacting Cyan support they may not know about this problem;
http://support.cyan.com/
falcon_x Mar 31, 2014 @ 10:51pm 
Disable DEP for Myst and it will run in Windows 7.
Last edited by falcon_x; Mar 31, 2014 @ 10:51pm
Flamesword Jan 18 @ 12:14pm 
Originally posted by Neph:
\Within that folder, find the application. It should end in .exe
I have the original DVD release of Myst: Masterpiece Edition, so I don't know how different the Steam version is, but my version has 24 exe files on the disk. There are 2 that could be the right one: ck.exe (the autorun file) and Myst.exe. However, neither of them work. Any idea how I can get it to work on Windows 8? I got RealMYST working, but I Masterpiece Edition has more content.
Noitalever Jan 18 @ 2:21pm 
Originally posted by Flamesword:
Originally posted by Neph:
\Within that folder, find the application. It should end in .exe
I have the original DVD release of Myst: Masterpiece Edition, so I don't know how different the Steam version is, but my version has 24 exe files on the disk. There are 2 that could be the right one: ck.exe (the autorun file) and Myst.exe. However, neither of them work. Any idea how I can get it to work on Windows 8? I got RealMYST working, but I Masterpiece Edition has more content.

Technically RealMyst has more content. It should be Myst.exe, try running it in compatibility mode for the installation for the latest operating system listed on the case. After you have finnished installing you will need to right click on the icon for starting the game and set it to the same compatibility settings you used for the install.
stevenloveland Jan 19 @ 1:20am 
Originally posted by Flamesword:
Originally posted by Neph:
\Within that folder, find the application. It should end in .exe
I have the original DVD release of Myst: Masterpiece Edition, so I don't know how different the Steam version is, but my version has 24 exe files on the disk. There are 2 that could be the right one: ck.exe (the autorun file) and Myst.exe. However, neither of them work. Any idea how I can get it to work on Windows 8? I got RealMYST working, but I Masterpiece Edition has more content.

If that doesn't work out you can try ScummVM

The steps are:
Install ScummVM, the latest development build (http://buildbot.scummvm.org/builds.html)
Make a copy of all the files from your CD ScummVM requires on the list here (http://wiki.scummvm.org/index.php/Datafiles#Myst) in a folder (I'd name it Myst)
Place the folder in Your ScummVM folder (Easier to find)
Run ScummVM and click "Add Game"
Open the folder you put the files into and click "Choose"
Click "OK" again to run the game defaults

You should be able to run the game no problem
Last edited by stevenloveland; Jan 19 @ 1:42am
Showing 1-7 of 7 comments
< >
Per page: 15 30 50