Mental Floss Feb 6, 2013 @ 8:51am
How to stop Myst crashing?
So bought Myst, I had heard a lot about it, thought I would give it a try, had a few problems with the video but thankfully the people from the steam community managed to tell me how to fix that, after playing the game for a bit I can say that the game is amazing looking for its time, has a nice soundtrack and is very immersive.

And by Immersive I mean the game WOULD be immersive if the game didn't keep crashing every 5 seconds!

I really WANT to like this game, but I don't want to play a game that feels completely broken and unplayable, which is the current state of the game for me.
The game keeps breaking and I keep having to open Task Manager to close it.
Problems include the game crashing when I click on things, like the paintings in the book room, clicking panels on a door, one of the most notable examples of the game crashing is when I was TRYING TO LOAD A PREVIOUS SAVE.

Does anyone have any idea how to solve these issues? Even slightly would be great. I feel that Myst has the potential to be one of my favourite games but if the game keeps crashing after 5 minutes of gameplay then I can't enjoy it.

TL;DR Game doesn't work, Keeps crashing, any clue on how to fix it? - MF
Showing 1-15 of 15 comments
< >
Tomatoworm Feb 11, 2013 @ 11:11am 
I have the original version and it has the same problem. Strangely it even lags from screen to screen like my computer is too slow to run it. Which operating system do you have it installed on?
Mental Floss Feb 11, 2013 @ 12:05pm 
Originally posted by Tomatoworm:
I have the original version and it has the same problem. Strangely it even lags from screen to screen like my computer is too slow to run it. Which operating system do you have it installed on?
I use Windows 7. The game doesn't lag, the cutscenes work fine, more or less just stops working altogether.
TheRigGerMortis Mar 15, 2013 @ 5:53pm 
The exact same thing just happened to me. Literally after about 2 minutes the screen froze and I had to kill it. This was with Windows XP SP2 compatibility mode and an old version of Quicktime. I wonder if any other compatibility modes work?

Originally posted by Mental Floss:
Originally posted by Tomatoworm:
I have the original version and it has the same problem. Strangely it even lags from screen to screen like my computer is too slow to run it. Which operating system do you have it installed on?
I use Windows 7. The game doesn't lag, the cutscenes work fine, more or less just stops working altogether.
TheRigGerMortis Mar 15, 2013 @ 6:10pm 
Hey, I just tried Windows 95 compatibility mode and it didn't freeze for a long time. When it did the audio started to jump as if it had been slowed down, I did alt tab to get to Steam and when I did the sound went back to normal so I alt tabbed back to it and it was fine.

It might be annoying but it only took a second and I could continue playing. I'm on Win7 64bit so maybe just try that? It at least lets you play the game. Just alt tab out if it freezes. That's if yours froze for the same reason as mine.

Originally posted by Mental Floss:
Originally posted by Tomatoworm:
I have the original version and it has the same problem. Strangely it even lags from screen to screen like my computer is too slow to run it. Which operating system do you have it installed on?
I use Windows 7. The game doesn't lag, the cutscenes work fine, more or less just stops working altogether.
SMITH_uk85 Jul 15, 2013 @ 2:05pm 
I had a few crashes at the clock tower. I changed the .exe compatibility mode to Windows 98/ Windows Me [right click .exe>properties>compatibility tab>drop box>Windows 98/ Windows Me>apply/OK] and the crashes have stopped, but the audio is really bad and makes these horrible crackling sounds, like the audio is bitcrushed or something.

Edt: I no longer have the movies running in compatibility mode Windows 98/ Windows Me, I read in another thread XP service pack 2 is ok, the movies play now, but this is now randomly crashing while moving from screen to screen.

Edit: Downloading Quicktime 6.5.2 was metioned in another tread for a possible fix for the movies not playing, I've downloaded it and it hasn't crashed on me yet... and I'm now running in Windows 98/ Windows Me [this seems the most stable for me] and I've installed Quicktime 6.5.2. It seems OK now, but I'm going to change all the .mov files in the QTW folder to open in quicktime 6.5.2, as I think some of the movies are still missing from the game.

Last edited by SMITH_uk85; Jul 15, 2013 @ 2:44pm
Des5011 Aug 11, 2013 @ 1:43pm 
windows 98/windows me as standard setting+ activate 256 colour mode+resolution 640*480 and run it from your steam libary, then it works fine for me.
KFORCE-K4 Aug 14, 2013 @ 1:17pm 
windows 98 compatibility game me crashes. Then I switched to 95 and never crashed again. Sometimes the game will freeze for around 25 seconds, but then it will turn back to normal. Sound gets affected a lil bit, but thats better than getting the crashes.
devilheihachi Oct 6, 2013 @ 10:52am 
I had the same problem in Win7, frequent random crashing. First tried the XP SP3 and SP2 compatbility modes, neither worked even with 640x480 and/or 256 colors enabled nor running as administrator just for good measure. Win 98/ME compatibility with 640x480 works for me and with 256 colors is the only way I can save/load games. I still have to alt+tab to the desktop, then go back to the game for the save/load to complete - it's annoying but oh well. Plus the sound is horrible in 98/ME mode compared to XP SP2 or 3; but tolerable I guess. Anyway, hasn't frozen in about an hour straight of playing, which is much better than the 5 minutes or less freeze in the XP compatibility modes. I don't think the movies are working though; haven't tried an older Quicktime yet.
verschleierung Nov 13, 2013 @ 10:27pm 
Mine keeps crashing in clock tower. How do I edit Compatibility of Myst Masterpiece when it's a URL through steam? Changing Steam's compatibility doesnt seem to change performance.
Stumblina Nov 15, 2013 @ 6:19pm 
verscheierung- I had the same issue. Go to Control Panel, search for Troubleshooting, choose Troubleshooting, then choose "run programs made for previous versions of windows." You will have to find where Myst is saved in your hard drive- Steam will indicate where when you intall Myst. You can always uninstall/reinstall Myst to see where the file was saved on your hard drive. Then just follow the prompts.
verschleierung Nov 18, 2013 @ 7:23pm 
and you had luck with this?
Stumblina Nov 26, 2013 @ 7:19pm 
Yes, works pretty well for me.
Geek Goddess Jan 1 @ 1:29am 
I followed these instructions to get Myst to run without crashing in Windows 8: http://www.gog.com/forum/myst_series/why_wont_myst_masterpiece_edition_run_on_windows_8

Upon saving, the game did still freeze for a minute and the sound would get messed up, but if I simply waited, it passed. I was able to finish the game without problems.
Gary Ruseman Jan 3 @ 7:41pm 
You could try using an old compatibility setting? I've had friends with similar troubles, but I can't recall how they resolved them.
Noitalever Feb 19 @ 12:43pm 
Try contacting Cyan support they may not know about this problem;
http://support.cyan.com/
Showing 1-15 of 15 comments
< >
Per page: 15 30 50