codyeo Oct 26, 2013 @ 10:55am
So this was a ripoff...
So after some google researching I was finally able to get my version of Myst I just downloaded off of Steam to start playing properly (ie. videos). But now the game consistently crashes at certain spots on the island and is comepletly inhibiting the game.

My question for Steam/Cyan...

Why the hell offer to sell people (for real money) a game that will not work on their modern PC. I feel ripped off. Thankfully I only paid five dollars, but I very easily could have downloaded a torrent version of this game that would have run just as stable.

Basically, please do some kind update to this game because I do not want to have to purchase realMyst or something to be able to play properly. If people are still willing spending money on the game, please allow them to be able to play it without hastle.
Showing 1-13 of 13 comments
< >
KFORCE-K4 Oct 26, 2013 @ 5:49pm 
Another quick google research would have taught you that you have to run the game in compatibility mode. I can watch all the vids, the game never crashes, but still freezes for 15-20 seconds everytime I save. Better than nothing.
codyeo Oct 28, 2013 @ 3:00pm 
haha trust me i have run it in many different modes, even installed an old version of quiktime. still freezes at certain moment
Jeremiah uTO^ (†CDc) Nov 3, 2013 @ 8:39pm 
Works fine for me on Win XP. Vista and Win 8 are well known for not allowing older programs to work. Blame Microsoft for changing windows instead of the developer who made this game.

There is a reason this exact version of this game was a blockbuster making over $1,000,000.
Τhe Rolling Cheese Wheel Nov 5, 2013 @ 11:26am 
Must be Pebkac, game works fine on my end.
Paul Nov 15, 2013 @ 3:11pm 
If you're on Win7, go to the Myst.exe file in your Steamapps folder (usually C:\Program Files (x86)\Steam\SteamApps\common\Myst Masterpiece). Right click > Properties > Compatibility. Run this program in comp mode for "Windows 98 / Windows Me", Run in 640 x 480 screen res, Disable visual themes, Disable desktop comp, Disable display scaling, Run program as administrator. Only freeze you will encounter is with either saving or loading, might take 20-30 seconds (maybe some sound issues but no crashing).
savaka Jan 8 @ 2:48pm 
Originally posted by mechabit:
If you're on Win7, go to the Myst.exe file in your Steamapps folder (usually C:\Program Files (x86)\Steam\SteamApps\common\Myst Masterpiece). Right click > Properties > Compatibility. Run this program in comp mode for "Windows 98 / Windows Me", Run in 640 x 480 screen res, Disable visual themes, Disable desktop comp, Disable display scaling, Run program as administrator. Only freeze you will encounter is with either saving or loading, might take 20-30 seconds (maybe some sound issues but no crashing).
Don't forget that you have to install an old version of QuickTime
zach.charland Jan 18 @ 9:58pm 
I personally just use the GOG version, same for Riven and have had zero issues. I feel kind of guilty promoting another distributor on here, but the GOG versions are significantly better in terms of bugs and such.
Joshego Jan 21 @ 4:29am 
after i did such thing, i cant launch the game due to missing excutive error.
Originally posted by mechabit:
If you're on Win7, go to the Myst.exe file in your Steamapps folder (usually C:\Program Files (x86)\Steam\SteamApps\common\Myst Masterpiece). Right click > Properties > Compatibility. Run this program in comp mode for "Windows 98 / Windows Me", Run in 640 x 480 screen res, Disable visual themes, Disable desktop comp, Disable display scaling, Run program as administrator. Only freeze you will encounter is with either saving or loading, might take 20-30 seconds (maybe some sound issues but no crashing).
Noitalever Feb 19 @ 12:41pm 
Try contacting Cyan support they may not know about this problem;
http://support.cyan.com/
Steiner May 29 @ 6:47am 
Cyan will probably tell you that you can buy the update for 12 dollars more.
DrDefrag Jun 29 @ 12:59pm 
I fixed the problem easily (WINDOWS 7) by simply right clicking the game in your library in steam and click properties > select local files tab and click browse to local files > navigate to the exe file right click select properties > click compatibility tab > select to play in Win XP SP 2. Loads up and plays in game videos like a charm. Hope this helps.
Pardinuz Jul 1 @ 5:29pm 
I've had no issues running it on with Admin privileges, Windows 98 compatibility mode and visual themes turned off.
JearBear Jul 8 @ 10:38am 
Is there any sort of easy-download patch for this? Seems like that would be the way to go.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50