Baron von Penguin Nov 25, 2013 @ 4:50pm
Is the imager busted?
I'll try not to spoil anything, but when I got into the chamber by the dock and entered the number of marker switches and hit the red button, nothing seems to happen. Did I do something wrong?
Showing 1-8 of 8 comments
< >
cpants Dec 20, 2013 @ 6:40pm 
I'm right there with you Friendly. In fact I can't even get the videos in the library books to play. The frame just remains black
Baron von Penguin Dec 20, 2013 @ 8:00pm 
I did some looking around, and it appears we might not be running the game properly. Try going into the game files, right-click on the Myst application, click properties, then hit compatibiltiy. The game needs to run in compatibility mode. I hope this helps. It helped me, that's for sure.
RSDJ Dec 27, 2013 @ 11:31am 
This actually screwed up the experience for me. It was actually my first time playing Myst and inputing the codes in the message chamber didn't do anything. I was confused.
savaka Jan 8 @ 2:47pm 
You have to run it as administrator in compatibility mode with a really old version of QuickTime installed for anything to work right.
Baron von Penguin Jan 8 @ 3:36pm 
How can I obtain a really old version of QuickTime? And which version would you recommend?
imamarvelfreak Jan 15 @ 9:55am 
I have almost the same problem when i get into the clock and try to pull the lever it freezes on me. I right clicked the myst app and it didn't have a compatibility mode with it so i had to troubleshoot compatibility program and it helped a little but still froze in the same place. Does anyone know what to do?
Joshego Jan 21 @ 4:52am 
on windows7 64bit system, i tried everything, finally GOG version of myst worked, steam version is busted, forget about it, its a 5 dollars of waste of time. download a GOG version, instal a quicktime 6, copy the 'quicktime.qts' file from folder 'C:\Windows\SysWOW64' into ur GOG myst root folder. uninstal quicktime 6 and install the latest version of quicktime. right click on myst.exe in campatitive mode select windows 98/me & tick all boxes underness, comfirm, start the game and all video is good to go.
Noitalever Feb 19 @ 12:43pm 
Try contacting Cyan support they may not know about this problem;
http://support.cyan.com/
Showing 1-8 of 8 comments
< >
Per page: 15 30 50