realMyst > General Discussions > Topic Details
Beil Aug 21, 2012 @ 4:17am
This game is either porrly optimised, or my computer just hates it.
Whenever I open it, the framerate drops to about 3 once i click on the book. In the starting area, if you go to the cave to your left immediately, it's fine in there, bute everything else is just horrible. Any ideas?
Showing 1-13 of 13 comments
< >
sto-ifics42 Aug 22, 2012 @ 1:19pm 
Dunno. This game seems a bit glitchy at times for me too. I'm not great at troubleshooting, but I'd try messing around with compatibility options.
PsychoDan Aug 23, 2012 @ 7:00pm 
If I remember right, it runs much better under Windows 98 compatibility mode. It's quite an old game, and only got a very cursory update to enable it to run on Vista/7 at all.
m.vanvrancken Sep 4, 2012 @ 8:58pm 
I'm getting this issue on Win7 too, I guess I'll try the compatibility tweak. I might mess with the graphics options, even though my PC should be running it fine, I have 8 gigs of RAM so there's no issue with that. I just have no idea.
Shadgrimgrvy Sep 5, 2012 @ 10:37am 
Oh good, it wasn't just me then! On my first play though it ran perfectly but when I tried it again I got the same problem you're talking about. Maybe it would be worth it to try reinstalling?
MickJaz97 Sep 14, 2012 @ 5:45pm 
I found the problem. Modern computers don't seem to like rendering doors in the game. I only experience framerate drops when I'm looking at, or right next to a door.

EDIT: Correction, it has something to do with the library.
Last edited by MickJaz97; Sep 14, 2012 @ 6:27pm
The Expidition Sep 27, 2012 @ 6:48pm 
The compatability tweak got rid of an issue I was was having with the in-game movies, but caused the framerate drop for me.
Beil Sep 28, 2012 @ 1:30am 
I tried some compatibility options and it just made it worse for me. Anyone have any other suggestions? or will i have to install an older windows on a virtual box or something.
Wisnoskij Sep 30, 2012 @ 1:22pm 
You can try a reduced resolution, games runs fine so far for me when I set it to some medum setting.
Edward Nov 16, 2012 @ 5:06am 
I just bought it and had the same problem with slow downs and videos not playing, I put it on WinXP compatibility and turned on "Disable desktop composition", "Disable Display Scaling" and "Run as Admin" and it's working great now, don't know which one of those fixed it, I just left it like that since it's working fine.
georgech77 ♦Phant♦ Jan 20, 2013 @ 11:21am 
This may be a stupid question, but what do i click to find win xp compatibility and disable desktop composition?
amyca19 Mar 1, 2013 @ 1:35am 
Edward's fixes helped the lagging at doors, but still can't see video in the books.
georgech77, I didn't know how to change compatibility either, so I searched in Help & Support. It gave me a link to a compatibility wizard and it is very easy from there.
amyca19 Mar 1, 2013 @ 1:47am 
Actually, do it this way: For realMYST try searching your steam folders for RealMYST.exe. Right click on it, and select Properties. Then Compatibility and check the boxes, Apply, and you should be good to go!
Osldgoth Mar 21, 2013 @ 12:57am 
Originally posted by amyca19:
Actually, do it this way: For realMYST try searching your steam folders for RealMYST.exe. Right click on it, and select Properties. Then Compatibility and check the boxes, Apply, and you should be good to go!

awesome, this made the game work 100% for me, thx
Showing 1-13 of 13 comments
< >
Per page: 15 30 50