realMyst > General Discussions > Topic Details
Groctel Apr 25, 2013 @ 12:31am
Overpowered 3D makes this unplayable D:
I am a huge fan of Myst games. I started playing it when I was 2 or 3 years old and I have been playing them until now. When I got my new laptop I didn't doubt and get this game (first time my laptop didnt crash with games, long story short: it was broken). So I open it and what happens? TOO MUCH 3D D: I cannot walk by the library or the boat columns because the 3D models make my laptop go really slow. Is there any way of changing it? Thank you ♥
Showing 1-10 of 10 comments
< >
Mister Bubbles Aug 23, 2013 @ 11:52pm 
This is a really old game, and your 'new' laptop can't cope with the graphics?

Run the setup and lower some of the settings.
Groctel Aug 24, 2013 @ 5:02am 
Still, The 3D models used in RealMyst slow my laptop too much, while I can play other games with even more models at 60fps
Elenoe Aug 25, 2013 @ 2:48pm 
XP SP3 compatibility needed, otherwise it is terribly laggy on modern systems. Set that up on realmyst.exe and it has at least chance to work properly for you.
Last edited by Elenoe; Aug 25, 2013 @ 2:49pm
Vchat20 Aug 25, 2013 @ 2:58pm 
Chiming in along with Elance. Especially if you're 'new' laptop has Windows 8, I find it conflicts a ton with these older games. One specific game from the era I could barely hit 15fps at 800x600 on Win8 but could go full 60FPS at my native 1680x1050 res on 7. I won't claim it is ALL Windows 8's fault, just trying to run older games on 3 or 4 generations newer of an OS. Try the compatibility mode or downgrade is all I can say.
Mister Bubbles Aug 26, 2013 @ 5:29am 
NOTHING to do with graphics cards, 3D models or Operating systems. Stop "blaming" these aspects that are unconnected tot the issue.

The issue is with your native monitor resolution. That's all.

The game was niot written with widescreen/lb in mind, and as such, when fullscreen applications are run at different RAR's the display must be scaled to fit.

Games written in days of 640x480 or 800x600 as "typical" 4:3 RAR's, would be stretching picas on the display of 2x1.5 at LEAST on a 1600x900 Panasonic display.

Needing to scale up DPI in this manner, especially when non-unilateral dimensionally, EVERY FRAME was never considered a necessary optimisaton in the game, since wuch displays were pretty much unheard of, so it remains as a huge overhead to the speed of rendering.

FIX 1:
If your Monitor and GPU support 4:3 RAR, try setting your desktop to one, even if it's 10245x768 or smaller

FIX 2:
On Windows releases 6.x, use compatibility modes, and check the "Disable Scaling" if present.

FIX 3:
Use a monitor screen that supports 4:3 RAR and see #1 above.
bryonhowley Feb 8 @ 4:17pm 
It is really simple really you are running a game on a laptop that was NEVER intended to ever be run on a laptop. Simply put your laptop does NOT have the power to run games at all. Lower the settings and resolution to the minimum and then maybe you can run it OK but I would not count on it even then.

If you really want to game get a desktop next time that is the ONLY way to fix the problem period.

It is simple your latop is way underpowered to play games. It has nothing at all to do with the age of the game because as far as RealMyst goes the "3D" is all pre-rendered frames it is not true 3D and there for is not the cause of the problem.
{P4TM} Chef Apr 21 @ 5:00pm 
OP. Read post #5 then lol @ post #6.
Groctel May 29 @ 6:47am 
Originally posted by {P4TM} Chef:
OP. Read post #5 then lol @ post #6.
+1
stephanbertram Jun 30 @ 10:03pm 
crashing and bugginess work around win 7 xp vista etc
crashing and bugginess work around win 7 xp vista etc
while trying to get this spectacular game to work i discovered compatibility mode which allows programs to run on an emulated older version of windows ie for riven windows 98 setting it to compatibility mode reduces the amount of crashes and bugs due to incompatible software coding etc its a simple fix that will take less than a minute

step 1 open steam
step 2 right click on myst riven etc
step 3 click on properties
step 4 click on local files tab
step 5 click browse local files
step 6 scroll till you find the game icon that is an application
step 7 right click on the game application
step 8 click on properrties
step 9 click on the compatibility tab
step 10 check the box that says run this program in compatibility mode for
step 11 select what version of windows you would like the game to be emulated in (riven works very well in windows 98/me and myst will work in 95 or 98/me)
step 12 check run program as administrator
step 13 click apply
step 14 click ok
step 15 play game normally and enjoy with a lot less problems

So enjoy my fellow adventurers and if you have any trouble or questions dont hesitate to ask i have a lot of tech experience and i am willing to share the knowledge any time hope this helps

-Stephan
Groctel Jul 1 @ 2:32am 
By the way, I solved it months ago, just play it in 4:3 resolution xDDD
Showing 1-10 of 10 comments
< >
Per page: 15 30 50