HOARD > General Discussions > Topic Details
grondinm Jan 15 @ 3:43am
Wont Load on linux
When i try to load the game from the steam client it just flashes and never loads. I navigated to the ~/Steam/SteamApps/common/Hoard/x86 folder and executed Reuben.bin.x86 manually but it gives me this:

Setting breakpad minidump AppID = 63000
dlopen failed trying to load:
/home/marcg/Steam/linux32/libsteam.so
with error:
/home/marcg/Steam/linux32/libsteam.so: cannot open shared object file: No such file or directory
dlopen failed trying to load:
libsteam.so
with error:
libsteam.so: cannot open shared object file: No such file or directory
Steam_SetMinidumpSteamID: Caching Steam ID: [API loaded no]
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
Segmentation fault
Last edited by grondinm; Jan 15 @ 3:44am
Showing 1-15 of 19 comments
< >
sagu Jan 17 @ 10:39am 
same here :/
Benjica Jan 18 @ 2:18pm 
I am experiencing the same issue. Is there a bug tracker to report to?
The Squirrel Jan 18 @ 4:24pm 
I know ♥♥♥♥all about linux. Is what you guys are saying that it comes up as "missing executable"? I don't know anything about linux so I don't know what any of that means, but I'm going to post a link here to a guy who seems to have solved this problem. Assuming its the problem you are having.

EDIT: Originally posted by orb:
The Linux version has been made public only on Jan 14 2014, at 22:48 UTC. Earlier it was in non-public beta testing for more than a month, and that's why there was "missing executable" / 0 bytes download.

The game should be working just fine on Linux. If it still doesn't, check the game cache or uninstall and install it once again.

I took that from a post I quoted in the FAQ thread I've attempted to start on this forum. If verifying cache/reinstalling fixes it for you please post so that we can add that as another successful solution.
Last edited by The Squirrel; Jan 18 @ 4:25pm
Omega Jimes Jan 19 @ 2:05pm 
I just got Hoard with the Humble Bundle and I have the same problem. When I launch it the screen flashes white, then it goes straight back to desktop. I'm not sure where I can find any logs pertaining to this. I was pretty psyched to play this today.

Running Mint 16 cinnamon, Linux Kernel 3.12.0, 6950 2GB with FGLRX 13.101-0ubuntu3
nickbuss72 Jan 20 @ 3:11am 
I have this problem as well. Running Mint 16 64bit with an ATI 5750, open drivers brings up a black screen and plays music, FGLRX crashes back to desktop after a brief black screen.
mitscherdinger Jan 21 @ 3:46pm 
I'm using the open radeon-drivers, too. Black screen and music, nothing more.
Have we all got the same GPU-manufacturer (AMD)?
That would tell us, where the problem is...
cap'n crunch Jan 21 @ 7:52pm 
Mine gets to the start-up screen with the 'Hoard' logo and the dragon, with the spinning circle of dots, then just hangs (with 50%CPU usage).

It works fine when installed separately without steam.

I have an "Intel Corporation Xeon E3-1200" video card.
mitscherdinger Jan 22 @ 1:40pm 
It would work om my system, I guess - if I could see, where I am clicking at... :)

Three drivers, three errors…
O.k., Big Sandwich Games - it is your turn to fix it.
jakub Jan 23 @ 1:23am 
It seems that it has big problems with 64 bit systems :( I can't run it too on ubuntu 13.10 64 bit, nvidia card.
mitscherdinger Jan 24 @ 12:45pm 
I've got a 32bit Debian Testing - so that doesn't seem to be the point.

Nvidia, also? Which driver?
cap'n crunch Jan 27 @ 7:55pm 
When I copy in the binary from the non-steam version it works fine (without any steam-ness obviously), and when I run the Steam-linked version from the CLI, it seems to stop just at the point where it would load the front menu (which is the same when running from steam).
lucifertdark Jan 28 @ 1:46am 
Ubuntu 13.10 64bit nVidia GeForce 9800 GT with the 319 proprietary drivers, the game is working perfectly for me.
NoXPhasma Feb 3 @ 2:26pm 
Linux Mint 13 x64 with Nvidia 660 GTX and 331.20 propritary driver. Works absolute fine.
Works fine here as well...ubuntu 13.10 x64 650gtx ti boost 331.38 driver
noccy Feb 8 @ 3:40pm 
Not working, Ubuntu 13.10 x64 ATI Mobility Radeon HD 4250 / OSS Drivers. Music works, steam overlay works, but game renders nothing except for an initial flash of garbage. Have to switch to another vt to kill it in order to get back to desktop.
Showing 1-15 of 19 comments
< >
Per page: 15 30 50