Portal 2 > General Discussions > Topic Details
questing_wolf Jul 21, 2013 @ 7:51am
fails to load
Try to run Portal 2, via shortcut or off of the Stream interface, and nothing happens. Shows a small gray window, then drops. No error msgs; just doesn't load.

I've tried the basics, restart, delete/reinstall, clear cache, remove drivers, update drivers, etc. Pretty much everything I've already read in the discussions. Needing a solution that's not one of these obvious things.
Showing 1-12 of 12 comments
< >
Ollie Jul 21, 2013 @ 8:38am 
Also have this problem.
fubuwearer1 Jul 21, 2013 @ 11:58pm 
Me too.(for years)
Last edited by fubuwearer1; Jul 21, 2013 @ 11:58pm
Graves Jul 22, 2013 @ 3:11am 
I seem to be able to get to the main menu but when i clock on something it will suddently freeze and close my computer i've tryed alot of stuff but if you find the solution before me please tell me :D
ShibeTheDoge Jul 22, 2013 @ 10:15am 
Try replacing/adding more Memory (RAM). My computer has 1.5 GB, but it crashes. I have another one, that has 2.0 GB, and it runs smoothly. But if you want to mess with RAM, You have to open your computer.
fubuwearer1 Jul 22, 2013 @ 10:19am 
Thanks, Colorsword it may be for others, but I have 10gigs.
ShibeTheDoge Jul 22, 2013 @ 10:23am 
:O
Sorry, that's all I know.
Last edited by ShibeTheDoge; Jul 22, 2013 @ 10:24am
fubuwearer1 Jul 22, 2013 @ 10:28am 
I have a feeling it has something to do with our video cards not being compatible, in some way with the software. Although I can't be sure my drivers are up to date. I have an amd radeon hd 7450. I wonder if others(with this problem) have a similiar video card?
fubuwearer1 Jul 22, 2013 @ 10:32am 
No need to be sorry you are just trying to help.
ShibeTheDoge Jul 22, 2013 @ 10:34am 
^u^
Graves Jul 25, 2013 @ 1:11pm 
I have browsed the internet and people with the AMD are often those with the problems, i got it too my self i can run for a short while and then it turns off my pc, in a blue-screen.
but for now the only solution i got to know is to update your cpu, try go to gigabyte's homesite and search for your motherboard and the updates avaiable and then you'll have to flash it to your driver.... all i know don't know how to flash it though ... :(
questing_wolf Jul 28, 2013 @ 5:31pm 
Found something that works.
Open msconfig.exe
Go to the services tab
Unclick "AMD External Events Utility
Restart computer
fubuwearer1 Jul 28, 2013 @ 6:52pm 
Worked for me. Thank you, very much, Wolf!
Originally posted by questing_wolf:
Found something that works.
Open msconfig.exe
Go to the services tab
Unclick "AMD External Events Utility
Restart computer
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Jul 21, 2013 @ 7:51am
Posts: 12