Portal 2 > 综合讨论 > 主题详情
timmc94 2013年2月13日下午1:49
Unable to rebuild test chambers
For some reason, all of a sudden I can't build any chambers in the level creation section. The first of the bars loads up to around 90% and stops. Any idea what could be causing this? It is happening every time I try it now, but it never used to.
正在显示第 1 - 15 条,共 50 条留言
< >
CosmicMuffin 2013年2月16日下午9:48 
Same problem here. I just started trying to build test chambers. I can't even rebuild the default "new" test chamber. Make a single change (add an item), try to rebuild, and it sits with the first bar "Building Geometry" at about 90%. If I delete that item, then try to rebuild again, I get the same result. Stopped before I've started - this is frustrating.

timmc94 - what platform are you using? I'm on a new (Late 2012 iMac 27"). This isn't a system limitation. Activity Monitor shows "portal2_osx" running less than 1GB of memory and under 12% CPU.
Rabiez 2013年2月17日上午12:44 
I'm also a Mac user. 10.6.8 to be exact. Same issue. I just made a new chamber and tried to rebuild it and getting stuck on "building geometry" at 95%. I even tried different layouts, older and new chambers. I'm not getting anywhere. I read somewhere they did updates this morning that caused it. But I've not heard if and when they are going to fix it.
最后由 Rabiez 编辑于; 2013年2月17日上午12:45
Rabiez 2013年2月17日上午11:18 
Any fix to this yet? I'm turning into GLaDOS, making chambers and no one to test them on.
timmc94 2013年2月17日下午6:06 
I'm running Mac OS 10.8.2 and the problem for me is at the exact same point. Steam is telling me right now it has a client update, so I'll try that and see if it fixes the problem.
Rook 2013年2月18日上午8:28 
Same... I'd love to get this fixed so I can work on my map!
Rabiez 2013年2月18日下午3:56 
Is this exclusively a Mac thing? I'm making tons of maps and I have no way to test them.
StormDragon 2013年2月18日下午8:34 
I have almost the exact problem all the bars load takeing an unusual ammount of time then it stops on the next load screen anf never gets anywhere if It's a single player chanber. It simlply crashes the game. I think the same glitch might be causing this but It's behaveing slightly diffrent since I'm useing PC. I have no way to confirm this it's just a theory.
Mitch McWiggins 2013年2月21日下午2:30 
Hi, same problem here. Mac 10.6.8, and this wasn't happening until just a few days ago.

Does anyone know if Valve admins (or, really, anyone who would know how to fix this) look at these discussions?

(And happy to find that it's not just me having the problem)
timmc94 2013年2月22日上午12:06 
This does appear to me a Macintosh-only problem. I installed Portal 2 on my Parallels VM of Windows 8 on my MacBook Pro -- which is having problems with Portal in OS X -- and it works fine with the Windows VM.

I have no idea if Valve sees these discussions, they may not even know this is an issue.
O Filthy O Tambourine O 2013年2月22日上午7:46 
I opened a ticket with support yesterday referring to this thread.
christianjesus (已封禁) 2013年2月22日下午1:31 
Steam is doing some work and the workshop will be on and off. Be patient and try again later.
tosontsengel 2013年2月22日下午9:45 
Same problem here with 10.8.2. mac. All of a sudden I can't build my test chambers.
ianthekirkland 2013年2月23日上午8:50 
Same here. OS X 10.8.2. 3.2 GHz Quad-Core Intel Xeon, 16GB RAM. I can't build jack. @Rabiez and @CosmicMuffin, I also tried rebuilding using a brand new test chamber and still got nothing.

I still have Parallels + PC Steam installed from my attempts to use the Portal 2 Authoring Tools, but it ran into problems recognizing my video card. Anyone know how do this or if it's even possible?
rharrington14 2013年2月23日上午11:51 
I believe this is the third thread created in the last few days, wish it wasnt happening, but im glad to see lots of people are all trying to get it fixed
Stupeflip|Tomn 2013年2月25日下午2:39 
OK so same here on 10.8.2 MacBoook Pro.
I did nothing else but updating Portal 2 on my Mac then on my PC where Steam was in offline mode on both of them. I'm using the last Steam Beta Client.
No error in the Console, just something about a file that has been exported (sorry I don't have the exact message), I thing the extension of the dil begins with a .v … Then few messages dealing with the chamber which is successfully autosaved.
Can't build nothing, even already built chambers.
最后由 Stupeflip|Tomn 编辑于; 2013年2月25日下午2:47
正在显示第 1 - 15 条,共 50 条留言
< >
每页显示数: 15 30 50
发帖日期: 2013年2月13日下午1:49
帖子数: 50