Portal 2 > 一般的な話題 > トピックの詳細
Shadow Master X 2013年2月9日 13時34分
Portal 2 Crashing
Okay, I need serious help. Portal 2 starts up then crashes at the loading screen (You know, the one after the valve/source logos). Crash meassage says "Portal2.exe is not working." I am running Windows Vista, and the game has never worked ever since I bought it. Support isn't very helpful, and is just making it a bit more complicated than it should be. I have:

Completely reinstalled Steam (Thrice)
Reinstalled the game (Twice)
Updated video drivers
Renamed steamapps to old_steamapps
Forced it to a different video mode
Ran computer in Safe Mode
Ran it with -autoconfig and -safe
Ran as Administrator
Revalidated game cache
Installed DirectX, PhysX, and VisualC++
Validated Authoring Tools Cache

Little help?
最近の変更はShadow Master Xが行いました; 2013年2月15日 14時00分
1-15 / 23 のコメントを表示
< >
Ericrct 2013年2月9日 14時20分 
Contact Valve.
Shadow Master X 2013年2月9日 14時32分 
Ericrct の投稿を引用:
Contact Valve.
Been there! Done that!
uglyfirestar 2013年2月9日 14時42分 
Same problem! halp!
Lee Hλrvey Schnozwλld 2013年2月9日 17時21分 
change audio frequency from 48000 to 44100, i did that once in my audio card
settings and it worked
PixlHero 2013年2月9日 18時05分 
I don't know if this will help, but try just shutting down your computer and restarting steam. I did this and it worked. It was with a different problem though
muuneez 2013年2月9日 19時27分 
i have done all that, tried restarting my computer and it still wont open
SonyJunkie 2013年2月9日 21時37分 
I had the exact same problem.

In the end I tried verifying the integrity of tool cache of Portal 2 Authoring Tools as well as the game and it seems to have done the trick for me.

I read this thread - http://steamcommunity.com/app/620/discussions/0/882960163729577056/
Shadow Master X 2013年2月10日 7時17分 
Lee Hλrvey Schnozwλld の投稿を引用:
change audio frequency from 48000 to 44100, i did that once in my audio card
settings and it worked
How do I do that?
Shadow Master X 2013年2月10日 7時22分 
SonyJunkie の投稿を引用:
I had the exact same problem.

In the end I tried verifying the integrity of tool cache of Portal 2 Authoring Tools as well as the game and it seems to have done the trick for me.

I read this thread - http://steamcommunity.com/app/620/discussions/0/882960163729577056/
Didn't work!
Hiro Felix 2013年2月10日 8時11分 
Exact same problem here. Valve hasn't been much help. Are you running on OSX or Windows?
Shadow Master X 2013年2月10日 8時36分 
Hiro Felix の投稿を引用:
Exact same problem here. Valve hasn't been much help. Are you running on OSX or Windows?
Windows Vista.
uglyfirestar 2013年2月10日 13時29分 
im running windows 7 and same problem
kennylucius 2013年2月13日 13時21分 
I'm running OSX and having a very similar problem. When I try to load game or start a new game, crashes before loading. Always crashes on the third dot from the end.

Reinstalled, etc...no help.
最近の変更はkennyluciusが行いました; 2013年2月13日 13時22分
uglyfirestar 2013年2月13日 15時21分 
I validated portal 2's files and it worked again (right click on portal 2, properties, then validate the files if you dont know how)
Serúcipé 2013年2月13日 17時37分 
I'm running OSX, and having the same problem as kenny.
But some other details are that when it crashes, the loading screen always freezes at the same spot, then the game just quits abruptly and I see my home screen. A message pops up saying, "hl2_osx quit unexpectedly."
Although this happened to me last year also, and it wasn't just Portal 2, it was anything running hl2_osx, including TF2. My friend told me to try validating the files and other things, and that never worked. Eventually it fixed itself again. But now the problem returned but is now only affecting Portal 2.
I hope this info will help find the source of the problem, 'cause I have no idea what it means.
1-15 / 23 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2013年2月9日 13時34分
投稿数: 23