Portal 2 > Discussioni generali > Dettagli della discussione
Shadow Master X 9 feb 2013, ore 13:34
Portal 2 Crashing
Okay, I need serious help. Portal 2 starts up then crashes at the loading screen (You know, the one after the valve/source logos). Crash meassage says "Portal2.exe is not working." I am running Windows Vista, and the game has never worked ever since I bought it. Support isn't very helpful, and is just making it a bit more complicated than it should be. I have:

Completely reinstalled Steam (Thrice)
Reinstalled the game (Twice)
Updated video drivers
Renamed steamapps to old_steamapps
Forced it to a different video mode
Ran computer in Safe Mode
Ran it with -autoconfig and -safe
Ran as Administrator
Revalidated game cache
Installed DirectX, PhysX, and VisualC++
Validated Authoring Tools Cache

Little help?
Ultima modifica da Shadow Master X; 15 feb 2013, ore 14:00
Visualizzazione di 1-15 commenti su 24
< >
Ericrct 9 feb 2013, ore 14:20 
Contact Valve.
Shadow Master X 9 feb 2013, ore 14:32 
Messaggio originale di Ericrct:
Contact Valve.
Been there! Done that!
uglyfirestar 9 feb 2013, ore 14:42 
Same problem! halp!
Lee Hλrvey Schnozwλld 9 feb 2013, ore 17:21 
change audio frequency from 48000 to 44100, i did that once in my audio card
settings and it worked
PixlHero 9 feb 2013, ore 18:05 
I don't know if this will help, but try just shutting down your computer and restarting steam. I did this and it worked. It was with a different problem though
muuneez 9 feb 2013, ore 19:27 
i have done all that, tried restarting my computer and it still wont open
SonyJunkie 9 feb 2013, ore 21:37 
I had the exact same problem.

In the end I tried verifying the integrity of tool cache of Portal 2 Authoring Tools as well as the game and it seems to have done the trick for me.

I read this thread - http://steamcommunity.com/app/620/discussions/0/882960163729577056/
Shadow Master X 10 feb 2013, ore 7:17 
Messaggio originale di Lee Hλrvey Schnozwλld:
change audio frequency from 48000 to 44100, i did that once in my audio card
settings and it worked
How do I do that?
Shadow Master X 10 feb 2013, ore 7:22 
Messaggio originale di SonyJunkie:
I had the exact same problem.

In the end I tried verifying the integrity of tool cache of Portal 2 Authoring Tools as well as the game and it seems to have done the trick for me.

I read this thread - http://steamcommunity.com/app/620/discussions/0/882960163729577056/
Didn't work!
Hiro Felix 10 feb 2013, ore 8:11 
Exact same problem here. Valve hasn't been much help. Are you running on OSX or Windows?
Shadow Master X 10 feb 2013, ore 8:36 
Messaggio originale di Hiro Felix:
Exact same problem here. Valve hasn't been much help. Are you running on OSX or Windows?
Windows Vista.
uglyfirestar 10 feb 2013, ore 13:29 
im running windows 7 and same problem
kennylucius 13 feb 2013, ore 13:21 
I'm running OSX and having a very similar problem. When I try to load game or start a new game, crashes before loading. Always crashes on the third dot from the end.

Reinstalled, etc...no help.
Ultima modifica da kennylucius; 13 feb 2013, ore 13:22
uglyfirestar 13 feb 2013, ore 15:21 
I validated portal 2's files and it worked again (right click on portal 2, properties, then validate the files if you dont know how)
Serúcipé 13 feb 2013, ore 17:37 
I'm running OSX, and having the same problem as kenny.
But some other details are that when it crashes, the loading screen always freezes at the same spot, then the game just quits abruptly and I see my home screen. A message pops up saying, "hl2_osx quit unexpectedly."
Although this happened to me last year also, and it wasn't just Portal 2, it was anything running hl2_osx, including TF2. My friend told me to try validating the files and other things, and that never worked. Eventually it fixed itself again. But now the problem returned but is now only affecting Portal 2.
I hope this info will help find the source of the problem, 'cause I have no idea what it means.
Visualizzazione di 1-15 commenti su 24
< >
Per pagina: 15 30 50