Portal 2 > General Discussions > Topic Details
SocialSmiffie Jan 7, 2013 @ 12:45pm
Portal 2 Not Working
I am relitavley new to Steam, and Portal 2 is the first game I have purchased from here. I have one other game, Minecraft and it works perfectly, although, not a Steam game. I own a PC, not a Laptop. It is a 32-Bit Acer AcerPower with Intel Pentium 4 HT inside, designed for Microsoft Windows XP and Windows 2000. It also has a 16x DVD Disc Drive. So as you can tell, its all pretty crud. Now,back to the main topic. Portal 2 Works: It opens and runs well in menus. It plays all the animations, the Extras videos work and Test Chamber Creation works. But the main problem is within gameplay. If I start up Sinlge player, or even if I want to access and play community chambers, this is what happens: ALL of the sound works, according to single player I have no issues with the controls as it tells me, the crosshair appears and the blue and orange portal indicators around the crosshair works also and they change color if I shoot the portals. BUT, there is no screen. I cannot, cannot view any of the graphics or content. It just simply shows a black screen. Thats it, and it really frustrates me! I have gone through all the settings I can and can understad to change, but no solution yet. I would really like some help with this to get it working so I can play what I paid for. Any information needed, I will try my best to rechieve for any helpers, but yes, this is my agrovating standstill. I would really appriciate some help here. I am saving up for a Laptop and hope I will eventually get one, but that may take the whole year yet, so I could really do with some assisstance now, please!

Smiffie2
Showing 1-4 of 4 comments
< >
Med-x Jan 7, 2013 @ 1:32pm 
Hm, I haven't encountered this issue. I'd try to google it, as I'm sure I've heard of other people experiencing this.

In case it might help: To get the game to run, I had to go to msconfig and disable AMD External Events Utility from Services, then restart. Once that is done, I have to restart my pc before I play Portal 2.... Maybe that might help you too (assuming you have an AMD card) even though they are different issues?
Count Reptile Jan 7, 2013 @ 1:54pm 
try running lower settings maybe for video in options for portal 2 i experienced this from a laptop also but with css it was down to non suitable gfx card for that game maybe this is your problem if not later
SocialSmiffie Jan 9, 2013 @ 10:36am 
Thanks guys, hmm, yeah, I do believe the Graphics Card may be the issue as I spoke to an IT specialist about it at my course. Thanks for the help though! If you guys wouldn't mind, could you play my Test Chambers and give feedback if there is anything I need to do to edit it as I can't test them personally. It's called iTestChamber Part A. Thanks again!
cavidoge Jan 9, 2013 @ 10:46am 
Originally posted by smiffie2:
Thanks guys, hmm, yeah, I do believe the Graphics Card may be the issue as I spoke to an IT specialist about it at my course. Thanks for the help though! If you guys wouldn't mind, could you play my Test Chambers and give feedback if there is anything I need to do to edit it as I can't test them personally. It's called iTestChamber Part A. Thanks again!

I'd be proud! Good luck.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Jan 7, 2013 @ 12:45pm
Posts: 4