Portal 2 > General Discussions > Topic Details
ATLAS1192 Dec 15, 2012 @ 10:55am
Portal 2 Lag Spikes
I haven't seen a discussion like this after a search, and I couldn't find anything on Steam Support related to these issues, so I figured I would make my own thread about it. This isn't isolated to Portal 2, I've noticed it happening in any single player Source engine game (except Left 4 Dead 1 & 2, for some reason). I can play just fine for a while, but then I get random lag spikes for 60-70 seconds at a time. For example, I'll play just fine for 10-15 minutes at a near-constant 35-60 fps, but during these lag spikes, the framerate will drop to 5-20 fps. I may have deduced these spikes to an issue related to DirectX 9. I say this because, in older source engine games that support DX8 (HL2 Series, Portal 1), if I switch to DX8 modes, these lag spikes cease to be. If someone could help me with this issue, I would be grateful. Thanks in advance!

System Specs (in case they help, it's a dinosaur, don't laugh at me)
CPU: Pentium 4 3.0GHz
GPU: XFX GeForce 9600 GSO 768MB
RAM: 1 GB
OS: Windows XP Professional SP3 (32-bit)
HDD: 160 GB
Showing 1-3 of 3 comments
< >
Der Übergooper Dec 15, 2012 @ 1:58pm 
I've got no problems with dual 2,7 GHZ, ATI Radeon HD 2600 XT, 2 GB and W7 Ultimate 32-bit

I think your problem might be related to Windows, as Windows 7 made huge improvements in DirectX support. Otherwise, it might be your low RAM memory. Does it only occur at moments that are either graphically intense, or require a ♥♥♥♥load of calculations? (For example, moving surroundings such as in courtesy call or the awakening)
ATLAS1192 Dec 15, 2012 @ 3:44pm 
No, the spikes appear to be completely random in occurence.
After a bit of testing with HL2 on DX9, I found that turning down a few settings made the spikes less frequent, maybe even stopped them (didn't have a single noticeable lag spike in the entire 1 hour session). I'm unsure of which setting causes it, but I'll investigate a little more.
Der Übergooper Dec 16, 2012 @ 12:24am 
It might be the shaders, or the anti-aliasing
I would love to hear from you whenever you find the problem XD
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Dec 15, 2012 @ 10:55am
Posts: 3