Portal 2 > General Discussions > Topic Details
Aprilinator May 17, 2013 @ 12:37am
Portal 2 Crashes on Startup?
I've had portal 2 for quite a while, and never had problems with it before now.

When I start it up, everything seems to work fine until I get to the loading screen just before the main menu, and it crashes to the desktop.

I've tried updating drivers and verifying the game cache and still have the same problem.

Anyone know how I can fix this (I don't really want to re-download it if I can avoid it as I don't get a lot of bandwidth)

Thanks!
Showing 1-15 of 30 comments
< >
NSANE May 17, 2013 @ 1:06am 
also happens to me.
Nogard Faith May 17, 2013 @ 12:33pm 
same here I went to play it, it gets as far as the title screen than crashes never happened before to me till today, I'm re-installing it.
Last edited by Nogard Faith; May 17, 2013 @ 12:45pm
Ozymandis May 17, 2013 @ 12:44pm 
same!
Ozymandis May 17, 2013 @ 12:55pm 
just validated local files and it works now :yay:
Moulders May 17, 2013 @ 1:07pm 
I had a similar issue, Mine was because I had mumble running in the background -.-
Sniper At The Gates Of Hell May 17, 2013 @ 3:35pm 
try "-autoconfig" without "" as a startup parameter
J_Dawg_19 Jul 16, 2013 @ 10:49pm 
I bought Portal 2 and I launched it immediately in an anxious flurry to play this wonderful game. Upon launching the game, it crashed. I did a lot of research on how to fix it and I used this page but to no avail. After a long night at about 4 AM last night I decided to flash my bios. It failed and my computer was rendered a paperweight. That being said I was finally able to fix it at the cost of many things on my hard drive, including my windows office programs and such. I reinstalled Windows 7, Steam, and Portal 2. After 36 odd hours of trying to fix it, I finally did it. I sacrificed over $100 worth of programs to play this game (which I've already played and beaten) that only costed me $5... Yeah, I think I might have a mental issue but now I can play PORTAL 2!
WRS Jul 17, 2013 @ 12:07am 
same problem here.
Maybe is the itime to say goodbye to XP...
untitle323 Jul 17, 2013 @ 3:52am 
the same, can't solve for few days, wondering what should do
Zigzag Jul 17, 2013 @ 5:53am 
Same Prob, an earlier response said validate game files. im gonna try that
ive noticed that it stopeed working right after the steam update. that tmight be a problem too

validaing steam files worked!
Last edited by Zigzag; Jul 17, 2013 @ 6:30am
BlistovMHz Sep 11, 2013 @ 12:08pm 
FYI - Windows 8 DX10/11 is installed by default, and includes most of the DX9 libs, but is missing some stuff. Manually install DX9 to get Portal 2 and Crysis 3 working.
http://www.microsoft.com/en-us/download/details.aspx?id=35
ihumpher Oct 31, 2013 @ 9:31pm 
Originally posted by BlistovMHz:
FYI - Windows 8 DX10/11 is installed by default, and includes most of the DX9 libs, but is missing some stuff. Manually install DX9 to get Portal 2 and Crysis 3 working.
http://www.microsoft.com/en-us/download/details.aspx?id=35

This worked for me. Thanks.
murlakatamenka Nov 16, 2013 @ 1:17pm 
Thanks, installing DirectX 9 libs helped as well (Win 8.1) !
MadMax3078 Nov 23, 2013 @ 11:31pm 
I already have DX9, I can't even get 10 nor 11. I'm using xp.
Philderp Jan 27 @ 6:07pm 
I'm having a similar issue, but when I try to verify game cache, it does nothing.
Showing 1-15 of 30 comments
< >
Per page: 15 30 50