Portal 2 > General Discussions > Topic Details
vertigoelectric Apr 24, 2013 @ 8:39pm
Portal 2 returns to main menu when trying to load co-op game
I've seen a handful of posts (all quite old) discussing this issue, however there was never any fix mentioned. I'd like to bring this to attention because it's really bugging me and my friend. We've been playing Portal 2 off and on ever since it was released, and just lately we've been having this issue.

Basically what happens is... I choose a map, then invite him to play, and it gets to "Downloading Test Chamber", after which it simply returns both of us to the main menu. It doesn't happen ALL of the time, but it happens enough that it warrants attention.

I'd like to discuss ways we can possibly fix this.

For the record, simply "having the other person" host is not an acceptable solution, although we did have him host one time and it worked then, but we'll need to try a few more times to see if it makes a difference. Regardless, I need a solution that will allow me to continue hosting all of our Portal 2 games.
Showing 1-8 of 8 comments
< >
Adam Strange Apr 24, 2013 @ 9:17pm 
I'm having troubles starting a co-op game myself. Both me and my friend are disconnected at the loading screen. We played fine yesterday though.
Adam Strange Apr 24, 2013 @ 10:12pm 
So we both restarted Steam and everything worked fine.
vertigoelectric Jul 11, 2013 @ 4:58pm 
It would be really nice if we can figure out a fix. The problem is still occurring.
Broockle Jul 12, 2013 @ 3:25pm 
Got the same issue. Me and my friend each try hosting a few times until the game launches normally and doesn't dump us onto the menu screen. Occasionally there's also a "Disconnected" Error message. We then both restart steam and sometimes that improves the odds of working. It's super annoying, a fix would be wonderful.
ProfDave64 Jul 13, 2013 @ 2:40am 
A friend and I have tried to play custom co-op levels a couple times. One pattern we've seen is that our attempts will fail until we both have the BSP file downloaded to this folder:

C:\Program Files (x86)\Steam\SteamApps\common\Portal 2\portal2\maps\workshop\

Or actually a subfolder that gets created with a name like "919016319179234974."

We just killed time, trying over and over to join (and also keeping our eye on that subfolder) until we found that Steam had downloaded a 7MB to 10MB BSP file into the directory (along with a small jpeg thumbnail).

Once we both had the BSP, we could then play.

Also, at one point today while trying to join for a game, I had the subfolder and the jpeg on my computer, while he had the subfolder, jpeg and BSP on his. So he emailed me the BSP file, I put it in my folder, restarted Portal & Steam (just to be safe) and then we could play.
ProfDave64 Jul 13, 2013 @ 2:42am 
PS. I'm assuming the problem is that it just takes a long time for Steam's servers to serve up the BSP files. If so, is there any answer for that problem? other than "Keep trying to start the game, and keep watching your 'maps\workshop' directory?"
Ellie Goulding Aug 9, 2013 @ 4:34am 
Any other more sucessfull solution?
TwentyThree Feb 15 @ 7:29am 
Having this problem at the moment! Any fixes?
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Apr 24, 2013 @ 8:39pm
Posts: 8