Portal 2 > General Discussions > Topic Details
Deagletine Deagalila Apr 22, 2013 @ 1:20am
Won't Launch
I've tried verifying integrity ♥♥♥♥. I've tried running as admin. I've tried re-installing. ♥♥♥♥ing nothing works.
Showing 1-15 of 17 comments
< >
100$ Apr 22, 2013 @ 2:39am 
yeah same problem for tme too, i can get to the menu but when i try to load or play new game it just crashes
Deagletine Deagalila Apr 22, 2013 @ 3:59am 
I managed to fix it...more or less. I installed it on my ASUS laptop and it works fine. Must be a problem with my HP desktop
Rex Apr 22, 2013 @ 10:47am 
Mine crashes after the loading screen when you launch it. :/
FORGOTTEN_SOUL Apr 22, 2013 @ 11:18am 
same problem but i wont even launch for me
FORGOTTEN_SOUL Apr 22, 2013 @ 11:40am 
did you all get it in the sale
Nix Galski Apr 22, 2013 @ 12:09pm 
to fix it I have easy way!
Nix Galski Apr 22, 2013 @ 12:10pm 
download Fixed Crack from torrent
totoz Apr 22, 2013 @ 12:16pm 
Originally posted by megaramp1080:
did you all get it in the sale

yep
ashlingmwilliams Apr 22, 2013 @ 1:13pm 
Same problem. It starts okay but when I try to load a save file or start a new game it shows a loading screen for a while and then just closes by itself. Goes right to the desktop like nothing happened. Doesn't say anything about a crash or an error.
Kaiwen (FR) Apr 22, 2013 @ 1:27pm 
Same Problem...
Kaiwen (FR) Apr 22, 2013 @ 2:28pm 
For me, problem solved like this:
-Right click on Portal 2
-Properties
-Set launch options
-Write "-window" (without the quotes)
guywjmail Apr 22, 2013 @ 2:55pm 
Same problem here. Little dialog comes up, disappears, then nothing. Yes I got it on sale. No fix?
guywjmail Apr 22, 2013 @ 3:39pm 
-window did not work here.
TheSovietUnion Apr 22, 2013 @ 3:51pm 
Originally posted by Kaiwen (FR):
For me, problem solved like this:
-Right click on Portal 2
-Properties
-Set launch options
-Write "-window" (without the quotes)

Oh my god, thank you so much. MIne works now :D
GTTeric Apr 22, 2013 @ 6:06pm 
I had this problem too... Tried the verify integrity thing and that didn't help. Tried re-installing without antivirus and all that jazz.

However, when I installed the latest driver for my graphics card it worked. Now I know many of you will be like "I already have the latest driver installed". I did too. But I downloaded it again and now it works. Not saying this is the 'be all end all' fix, but it worked for me so hopefully it helps someone else too.
Last edited by GTTeric; Apr 22, 2013 @ 6:06pm
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Apr 22, 2013 @ 1:20am
Posts: 17