Portal 2 > General Discussions > Topic Details
Unowninator Mar 22 @ 12:03pm
Portal 2's having some problems, like my subscribed maps not showing up.
It used to take a few minutes to finish loading them, but now it won't load any more maps after the 1st few.


Also, Energy Pellets no longer make any noise when they hit a wall or vanish.

Someone suggested I ask here, so I am. Can someone please help me?

Showing 1-15 of 24 comments
< >
piotr_mil Mar 22 @ 2:19pm 
I have the same problem. I tried all the usual things one does when encountering these problems: Verifying the game's cache, reinstalling the game, flushconfig. Nothing works.

Also, most maps are now in my history, rather in my queue. Even if I move them to the queue, it comes back to history next time I open Portal 2. These maps on steam shows up to be subscribed by me today, even though I've played them months ago.
Last edited by piotr_mil; Mar 22 @ 4:20pm
Blood Mar 22 @ 2:29pm 
I have downloaded many of these chambers and I am having the same issue.

Do they still exist or will I need to download them again?

Has a restriction been applied to the number of community chambers that can be displayed?

Is there a way to remove the maps from the existing queue (whilst keeping them on my hard drive) and replacing the list with those that I have not yet played, or those which I waould like to play again?

Thanks! :)
szymekx666 Mar 22 @ 4:58pm 
i had 1900+ all of them (history and queue) in catalog on hdd, when i delete files, they back any time when i run steam platform ;p
Manfred Von Karma Mar 22 @ 5:07pm 
Portal 2 isnt the only one having problems,
my subscribed addons for Shogun 2 and Gmod isnt working either.
Looks like the workshop is down again -.-
szymekx666 Mar 22 @ 5:25pm 
no, when i subscribe maps with in-game workshop all is fine, but queue is cleared when game is closing
Blood Mar 23 @ 3:05am 
It's the community chambers that keep me playing Portal 2. Does anyone know what is happening? Is it a bug?

Thanks :)
szymekx666 Mar 23 @ 8:40am 
I wrote yesterday to Steam Support and waiting for answer. I will post here what they say if they response
Blood Mar 23 @ 9:13am 
Thanks a lot :)
Unowninator Mar 24 @ 10:03am 
1:01 PM - Unowninator: Say, are ALL your subscribed maps showing up on Portal 2? For some reason, only a few of them do.
1:01 PM - Unowninator: Also, Energy Pellets no longer make a sound when they hit a wall or vanish.
1:01 PM - SjorsMaster [NL] (spnk41): Wtf ur right it wont load all
1:01 PM - SjorsMaster [NL] (spnk41): Just a few
1:01 PM - SjorsMaster [NL] (spnk41): Check console
1:01 PM - SjorsMaster [NL] (spnk41): C_GameInstructor::ReadSaveData failed to read GI.lesson.Swap_Split_Screen_Control

Can the problem be figured out from that last line?
Last edited by Unowninator; Mar 24 @ 10:03am
dire.fcs Mar 24 @ 10:13am 
I've got this:
On the console initial screen shows this (the 3 last lines on log startup console):

Unknown command "cl_thirdperson"
C_GameInstructor::ReadSaveData failed to read GI.lesson.Swap_Split_Screen_Control
An error occurred while attempting to download a file from the UGC server!

What is the UGC server?
dire.fcs Mar 24 @ 10:26am 
But somehow I can play new maps if I'm subscribing from the P2 game browser (happen today); (the chambers that were subscribed and didn't appeared) now can be subscribed as new too.
These are the folders on the HDD that seems to receive and save the chambers from subscription service:

C:\Program Files\Steam\userdata\**your steam reference**\ugc\referenced

C:\Program Files\Steam\SteamApps\common\Portal 2\portal2\maps\workshop
szymekx666 Mar 25 @ 4:02pm 
Okay people, they response, there is an answer from Steam:

"Thank you for contacting Steam Support.
Please exit Steam and go to the folder called C:\Program Files\Steam\ (this is the default location for a Steam installation - if you set a different installation directory, you will need to browse to it).

Delete all of the files in this folder except:
- Steamapps and Userdata folders
- Steam.exe (this file is listed as an application and features the black and white Steam logo)

Restart your computer.

Then, launch Steam.exe from within the Steam installation folder, and not from a pre-existing shortcut.
With Steam running, re-test the original issue.
Note: This process will not affect your currently installed games.
If the issue persists, make sure your network is optimized for Steam:

Title: Troubleshooting Network Connectivity
Link: http://support.steampowered.com/kb_article.php?ref=1456-EUDN-2493"


And i do this, except firewall/router problems because i haven't. Next what i do is unsubscribe all maps and then run Portal2, subscribe some maps and now is fine.
I hope You all can solve that problem this way too :)
piotr_mil Mar 25 @ 6:43pm 
Originally posted by szymekx666:
Okay people, they response, there is an answer from Steam:

"Thank you for contacting Steam Support.
Please exit Steam and go to the folder called C:\Program Files\Steam\ (this is the default location for a Steam installation - if you set a different installation directory, you will need to browse to it).

Delete all of the files in this folder except:
- Steamapps and Userdata folders
- Steam.exe (this file is listed as an application and features the black and white Steam logo)

Restart your computer.

Then, launch Steam.exe from within the Steam installation folder, and not from a pre-existing shortcut.
With Steam running, re-test the original issue.
Note: This process will not affect your currently installed games.
If the issue persists, make sure your network is optimized for Steam:

Title: Troubleshooting Network Connectivity
Link: http://support.steampowered.com/kb_article.php?ref=1456-EUDN-2493"


Sadly, it doesn't work. After I tried this, Portal 2 crashed on start. Verifying the game's integrity made it run, but the problem sadly still is present. Only some maps load in the queue.

Unowninator Mar 25 @ 8:08pm 
^ Same as me.
presto668 Mar 25 @ 8:11pm 
I have the same problem. I submitted a ticket to support but I guess I failed in my explanation of the trouble because I received a reply saying they closed the ticket because they "don't provide support for mods". I reopened the ticket and tried again tonight.
Showing 1-15 of 24 comments
< >
Per page: 15 30 50
Date Posted: Mar 22 @ 12:03pm
Posts: 24