Portal 2
Portal 2 > 일반 토론 > 제목 정보
K-9 2014년 2월 28일 오후 5시 32분
Portal 2 Linux Beta won't start; Crashes on startup
As the title says, the Portal 2 Linux Beta crashes on startup.

Attempting to run the executable directly gives me this:

./portal2_linux: error while loading shared libraries: libtcmalloc_minimal.so.4: cannot open shared object file: No such file or directory

I'm on Linux Mint, 64 Bit.
< >
19개 중 1-15 표시중
CUT THAT OUT! 2014년 2월 28일 오후 5시 59분 
same man, yester i could get to the title screen. Buts thats when i was running beta mode.
CUT THAT OUT! 2014년 2월 28일 오후 6시 04분 
hey guy i just got it running by going into properties and switching the beta instead of opting out, i did this yesterday but i guess theres a new unreleased update.
tcchenier 2014년 2월 28일 오후 6시 23분 
same here, not starting on Linux Mint 64 or steamOS
tcchenier 2014년 2월 28일 오후 6시 39분 
but yes, I got it working fine by entering beta... right click on game in the library, select options, then in beta tab, select beta. Probably similar in SteamOS, will try next.
K-9 2014년 2월 28일 오후 6시 52분 
I'm already in the beta. I tried all that before I posted this. Let me do a bit of experimentation...
K-9 2014년 2월 28일 오후 8시 52분 
Okay; I've fixed it. To anyone else having this problem:

Install the latest version of gperftools from https://code.google.com/p/gperftools/
Koufopoulos 2014년 2월 28일 오후 9시 03분 
I'm having the same problem using 64 bit fedora 19. I fixed it by opting into beta as well. I was having some issues with the game running at 100% on two of my i7 cores after playing for a while, so I wanted to see if the beta beta version was part of the reason. I didn't have gperftools installed, also not sure why you would need them, but installing them did not help.
K-9 2014년 2월 28일 오후 9시 06분 
I think it's because i didn't have the tcmalloc libraries before i installed gperftools.
Benelot 2014년 3월 29일 오전 7시 09분 
Then simply install libtcmalloc-minimal4. You do not need all of the dependencies of the gperftools.
K-9 2014년 3월 29일 오전 10시 34분 
Thanks, I didn't see libtcmalloc-minimal4 in the repositories before.
K-9님이 마지막으로 수정; 2014년 3월 29일 오전 10시 35분
Benelot 2014년 7월 18일 오전 2시 25분 
And by the way: I just tried to play portal2 on my amd64 architecture in linux mint. It seems that valve has compiled the game and has linked it against libtcmalloc-minimal4 x86. The amd64 version of libtcmalloc-minimal did not help but gave an wrong architecture error.

As I was running it on my linux mint, I had to download the package directly from here:
http://packages.ubuntu.com/raring/i386/libtcmalloc-minimal4/download

Then I followed this procedure taken from http://community.linuxmint.com/tutorial/view/370:
----------------
First we are going to install some 32-Bit libraries which are needed to run 32-Bit applications:

Open up Terminal and type:
sudo apt-get install ia32-libs

and enter your password if it asks

Now we are going to open in the Folder were you 32-Bit deb files is by using the command:
cd 'Folder Location'

Were folder location is (Of course enter the folder location) or go to the folder, right click and click 'Open In Terminal'.

Now we are going to force the 32-Bit deb to be forced into installing for the 64-Bit Linux Mint:
sudo dpkg -i --force-architecture package.deb
----------------
After I did that I could run portal 2 also on my amd64 machine. I had weird performance fluctuations on my device, the beginning of the game (in the room that is moved around) I had heavy control delays (about 100ms between button press and the reaction), but afterwards it was nearly possible to play on the highest video settings; and that on my 4 years old lenovo w500 laptop!
AndreiS 2015년 10월 2일 오후 1시 34분 
This is still a problem. What is the proper way to report this to Valve to bundle that lib?
thecoffeepanda 2015년 10월 9일 오전 7시 50분 
This problem suddenly arose on my workstation after the last update to ubuntu 15.04.
It presents itself like crashing immediately after launch with no visible indication to the problems origin. Upon checking the game library it only downloads 6,6GB of the original ~11GB of the game which get downloaded again and again when I verify the integrity of the game cache of which ~3400 files apparently are corrupted. I've already tried to reinstall the game multiple times, set the game into Beta through the settings and checked the status and compatibility of every possible source in the architecture of my system. It does look like a genuine bug in the game software itself.
𝓒𝔱𝔥𝔲𝔩𝔥𝔲 2015년 10월 9일 오후 5시 05분 
Wanna know what you should do? Buy a Windows computer.
thecoffeepanda 2015년 10월 10일 오전 5시 07분 
(͡ ͡° ͜ つ ͡͡°)님이 먼저 게시:
Wanna know what you should do? Buy a Windows computer.

That would be too easy now wouldn't it :P it works fine in a virtual windows machine so no need to allow that crappy system the full control over your system ^^ but the point remains valve issued the game to be compatible with linux in 2013 and it still issn't fully working so no matter any personal opinion about what's the better OS it's still an unfulfilled guarantee if the game has that major issues!
thecoffeepanda님이 마지막으로 수정; 2015년 10월 10일 오전 5시 13분
< >
19개 중 1-15 표시중
페이지당: 15 30 50

Portal 2 > 일반 토론 > 제목 정보
게시된 날짜: 2014년 2월 28일 오후 5시 32분
게시글: 19