Portal 2 > Algemene discussies > Details van topic
K-9 28 feb om 5:32nm
Portal 2 Linux Beta won't start; Crashes on startup
As the title says, the Portal 2 Linux Beta crashes on startup.

Attempting to run the executable directly gives me this:

./portal2_linux: error while loading shared libraries: libtcmalloc_minimal.so.4: cannot open shared object file: No such file or directory

I'm on Linux Mint, 64 Bit.
1-11 van 11 reacties weergegeven
< >
LEARNING OPENGL 28 feb om 5:59nm 
same man, yester i could get to the title screen. Buts thats when i was running beta mode.
LEARNING OPENGL 28 feb om 6:04nm 
hey guy i just got it running by going into properties and switching the beta instead of opting out, i did this yesterday but i guess theres a new unreleased update.
tcchenier 28 feb om 6:23nm 
same here, not starting on Linux Mint 64 or steamOS
tcchenier 28 feb om 6:39nm 
but yes, I got it working fine by entering beta... right click on game in the library, select options, then in beta tab, select beta. Probably similar in SteamOS, will try next.
K-9 28 feb om 6:52nm 
I'm already in the beta. I tried all that before I posted this. Let me do a bit of experimentation...
K-9 28 feb om 8:52nm 
Okay; I've fixed it. To anyone else having this problem:

Install the latest version of gperftools from https://code.google.com/p/gperftools/
Koufopoulos 28 feb om 9:03nm 
I'm having the same problem using 64 bit fedora 19. I fixed it by opting into beta as well. I was having some issues with the game running at 100% on two of my i7 cores after playing for a while, so I wanted to see if the beta beta version was part of the reason. I didn't have gperftools installed, also not sure why you would need them, but installing them did not help.
K-9 28 feb om 9:06nm 
I think it's because i didn't have the tcmalloc libraries before i installed gperftools.
Leviathan 29 mrt om 7:09vm 
Then simply install libtcmalloc-minimal4. You do not need all of the dependencies of the gperftools.
K-9 29 mrt om 10:34vm 
Thanks, I didn't see libtcmalloc-minimal4 in the repositories before.
Laatst bewerkt door K-9; 29 mrt om 10:35vm
Leviathan 18 jul om 2:25vm 
And by the way: I just tried to play portal2 on my amd64 architecture in linux mint. It seems that valve has compiled the game and has linked it against libtcmalloc-minimal4 x86. The amd64 version of libtcmalloc-minimal did not help but gave an wrong architecture error.

As I was running it on my linux mint, I had to download the package directly from here:
http://packages.ubuntu.com/raring/i386/libtcmalloc-minimal4/download

Then I followed this procedure taken from http://community.linuxmint.com/tutorial/view/370:
----------------
First we are going to install some 32-Bit libraries which are needed to run 32-Bit applications:

Open up Terminal and type:
sudo apt-get install ia32-libs

and enter your password if it asks

Now we are going to open in the Folder were you 32-Bit deb files is by using the command:
cd 'Folder Location'

Were folder location is (Of course enter the folder location) or go to the folder, right click and click 'Open In Terminal'.

Now we are going to force the 32-Bit deb to be forced into installing for the 64-Bit Linux Mint:
sudo dpkg -i --force-architecture package.deb
----------------
After I did that I could run portal 2 also on my amd64 machine. I had weird performance fluctuations on my device, the beginning of the game (in the room that is moved around) I had heavy control delays (about 100ms between button press and the reaction), but afterwards it was nearly possible to play on the highest video settings; and that on my 4 years old lenovo w500 laptop!
1-11 van 11 reacties weergegeven
< >
Per pagina: 15 30 50