Portal 2 > General Discussions > Topic Details
5th Feb 27 @ 6:11pm
Portal 2 Beta Beta on Linux, Can't Escape First Room :/
The game starts and I'm in the hotel looking room and absolutely nothing happens but a hum that is constant. I can run, jump and look around but the story never kicks in.

Isn't Wheatley supposed to be knocking at the door? He is currently taking one hell of a break :/

Edit: I forgot to mention, I'm on a current release of Kubuntu 13.10 64bit. Kernel version is 3.11.0-17-generic. AMD X4 965 CPU with 8GB of RAM. GTX 570 GPU with propietary Nvidia drivers 331.20.
Last edited by 5th; Feb 27 @ 6:16pm
Showing 1-8 of 8 comments
< >
ca$hmod$ Feb 27 @ 7:52pm 
You have to do stuff in the rooom
allenmaher Feb 27 @ 8:03pm 
if you are getting the no voices bug, turn on the subtitles it will help you do those things.
5th Feb 27 @ 8:44pm 
Possible Spoilers.

Turning on subtitles worked (Thanks allenmaher) but this game is absolutely nothing without the incredible voice acting. It looks like voices kick in after I do the second jump that wheatley leads me on with by telling me to say apple. prior to that though another bug is, I didn't get on screen hints as to jump, luckily I remember it from playing it a long time ago.

Once Wheatley and I crash through the wall, voice acting stops and the subtitles continue.
ca$hmod$ Feb 27 @ 8:46pm 
Originally posted by Ng Linuxzen λ:
Possible Spoilers.

Turning on subtitles worked (Thanks allenmaher) but this game is absolutely nothing without the incredible voice acting. It looks like voices kick in after I do the second jump that wheatley leads me on with by telling me to say apple. prior to that though another bug is, I didn't get on screen hints as to jump, luckily I remember it from playing it a long time ago.

Once Wheatley and I crash through the wall, voice acting stops and the subtitles continue.

Spoilers huh?
5th Feb 27 @ 9:19pm 
Originally posted by casemodsubuntu:
Spoilers huh?

Yeah, it was one of the funniest moments of the game and it being a surprise is what made it work.
5th Feb 28 @ 10:50am 
Originally posted by Glennh:
Have you tried this? https://github.com/ValveSoftware/portal2/issues/5#issuecomment-36083539
That worked perfectly, I do have sound in the beginning. Thanks!

Edit: I've played till chapter 4 and I can't find anything wrong. Perhaps the only tiny thing that does not get in the way but that I do not remember is the camera lens are a glowing white. I thought they were black. Otherwise, this is pretty good :)
Last edited by 5th; Feb 28 @ 12:03pm
5th Mar 2 @ 1:48am 
I had time to finish the game today and play some community test chambers. The game's only bug I could find was the voices not being heard at first but Glennh's solution did the trick for that.

No game hints in the sense of answering what Wheatley ask you to do in the room to get things going. If someone never played Portal 2, they'd get stuck and frustrated at this part. Other than this, the game ran without a hitch and didn't really feel like a beta at all.

My only gripe is, I don't remember experiencing this but on a GTX 570 too much goo on screen or ever hidden behind a wall can cause the game to stutter terribly. Playing this community map by Mevious (a frigging genius) really shows how bad the stutter is if you simply look at the wall that has all the goo pouring behind it. Not seeing the goo but just looking at the wall causes an incredible stutter and I've experienced this before with another map that was chock full of goo.

If the lag caused by the goo can be optimized, the game I'd say is 95% playable the way it was meant to be.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Feb 27 @ 6:11pm
Posts: 8