Portal 2 > General Discussions > Topic Details
AnxiousPompano Jun 22, 2014 @ 7:03pm
Portal 2 Won't Start Up
So I just got portal and portal 2 in the dual portal pack and portal 2 doesn't want to start up. I'm pretty sure I've tried everything and p2 won't start up. I am on the MacOSX version 10.6.8 and this is the error message I get in the console.

Last login: Sun Jun 22 19:01:34 on ttys000
Hasselblad-Demo-2s-MacBook-Pro:~ demoaccount$ /Users/demoaccount/Library/Application\ Support/Steam/SteamApps/common/Portal\ 2/portal2_osx ; exit;
Failed to load the launcher (dlopen(bin/launcher.dylib, 2): image not found)
logout

[Process completed]

If anyone can help I would love that so much! I've been looking forward to playing this for a while and it just doesn't work. I've tried everything. Future thanks hopefully!
Showing 1-15 of 26 comments
< >
RO0AR Jun 22, 2014 @ 9:22pm 
Similar situation happens to me... I just installed Portal 2 on my Mac (10.6.8) and it fails to launch. I click play, a small window states it's preparing to launch and then nothing. No error message, just doesn't launch.
Last edited by RO0AR; Jun 22, 2014 @ 9:22pm
Lama051 Jun 23, 2014 @ 12:59am 
Last patch caused more bugs than it solved for many users across all platforms, pray for fix or rollback.
asimon Jun 23, 2014 @ 1:20am 
it's the same thing for me
AnxiousPompano Jun 23, 2014 @ 8:35am 
Originally posted by Lama051:
Last patch caused more bugs than it solved for many users across all platforms, pray for fix or rollback.
So are they going to fix it later on and is it just stuck like that?
AnxiousPompano Jun 23, 2014 @ 8:36am 
Originally posted by RO0AR:
Similar situation happens to me... I just installed Portal 2 on my Mac (10.6.8) and it fails to launch. I click play, a small window states it's preparing to launch and then nothing. No error message, just doesn't launch.
That's exactly what I get. Whatever it is I hope they fix it soon.
Lisa_the_IBob Jun 23, 2014 @ 9:16am 
I'm guessing when they compiled it, it removed X.6.8 compatibility.
AnxiousPompano Jun 23, 2014 @ 9:39am 
Originally posted by Lisa_the_IBob:
I'm guessing when they compiled it, it removed X.6.8 compatibility.
Probably. I hope they fix it soon enough.
Lama051 Jun 23, 2014 @ 10:12am 
Originally posted by Lisa_the_IBob:
I'm guessing when they compiled it, it removed X.6.8 compatibility.

It is ♥♥♥♥ed up for Linux and Windows as well.
AnxiousPompano Jun 23, 2014 @ 10:37am 
Originally posted by Lama051:
Originally posted by Lisa_the_IBob:
I'm guessing when they compiled it, it removed X.6.8 compatibility.

It is ♥♥♥♥ed up for Linux and Windows as well.
My friend has a windows and it's not ♥♥♥♥ed up for him. :)
Shrek.com Jun 23, 2014 @ 11:11am 
Same for me
AnxiousPompano Jun 23, 2014 @ 2:14pm 
So is anyone working on fixing this stuff. Honestly I'd like to play some portal.
Frol Jun 23, 2014 @ 2:23pm 
по теребонькаем?
AnxiousPompano Jun 23, 2014 @ 2:51pm 
Originally posted by Frol:
по теребонькаем?
English? Sorry lol
KejeN_KejeN Jun 24, 2014 @ 2:47am 
Same for me on linux ( Ubuntu 14.04) game quits to deskop without any error message when trying to start a new game.
slarcheveque Jun 29, 2014 @ 7:11am 
Originally posted by RO0AR:
Similar situation happens to me... I just installed Portal 2 on my Mac (10.6.8) and it fails to launch. I click play, a small window states it's preparing to launch and then nothing. No error message, just doesn't launch.
Exact same OS (10.6.8) and problem. I've searched a bit and I found nothing to make it work.
Showing 1-15 of 26 comments
< >
Per page: 15 30 50
Date Posted: Jun 22, 2014 @ 7:03pm
Posts: 26