Portal 2 > General Discussions > Topic Details
jjgrl55 Jun 17, 2014 @ 10:45pm
Portal 2 Won't Start Since Update
Title says it all. Game won't launch since the update was put in place. I was playing the game just fine before that. I'm not super technical, but I did verify the game cache and all was well. I am running on a Mac, so OSX advice would be nice.

ETA: Portal 1 booted up with no problems.
Last edited by jjgrl55; Jun 17, 2014 @ 10:46pm
Showing 1-3 of 3 comments
< >
ronald.huygen Jun 18, 2014 @ 12:56am 
same for me
jjgrl55 Jun 18, 2014 @ 11:24am 
I did get the game to work! I had to upgrade my system to Mavericks (the newest OS X, it's free to download) and now it's working just fine.

I was attempting to open the game in a partition with Snow Leopard loaded on it (it's a long story why I had such an old OS on my Mac)......so I think my problem was just that my system was too old for the new update. Hope that helps anyone else who had this problem!
HBZK100 Jun 18, 2014 @ 12:06pm 
I had this exact issue, but I fixed it.

Go to portal 2 properties, then look for "verify integrity of game cache" or something to that effect. Let it run and it should work.

Originally posted by jjgrl55:
I did get the game to work! I had to upgrade my system to Mavericks (the newest OS X, it's free to download) and now it's working just fine.

I was attempting to open the game in a partition with Snow Leopard loaded on it (it's a long story why I had such an old OS on my Mac)......so I think my problem was just that my system was too old for the new update. Hope that helps anyone else who had this problem!

If verifying the cache doesn't work then follow what he says.^
Last edited by HBZK100; Jun 18, 2014 @ 12:08pm
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jun 17, 2014 @ 10:45pm
Posts: 3